Bug 177241 - Possible versioning problem in recent hpijs RPM causing dependency conflicts
Possible versioning problem in recent hpijs RPM causing dependency conflicts
Status: CLOSED DUPLICATE of bug 177230
Product: Fedora
Classification: Fedora
Component: hpijs (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-07 23:32 EST by John Guthrie
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-08 05:42:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Guthrie 2006-01-07 23:32:26 EST
Description of problem:
hpijs-0.9.7-4.2 was recently released as a Fedora Core 4 update.  First of all,
the version of hpijs that originally came with FC4 was hpijs-1.7.1-3.  So I'm
left wondering, why is the version number of hpijs going backward?  Second of
all, however, if I run up2date -u, I get the following:

There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
foomatic-3.0.2-19                        conflicts with hpijs < 1.5 

That is, foomatic-3.0.2-19 cannot co-exist with a version of hpijs that is less
that 1.5.  Since this version of foomatic actually comes with Fedora Core, it
seems like there is a versioning problem around here somewhere, but I don't know
if the issue is with hpijs, or if foomatic also needs to be updated as well to
allow this "new" version.

Version-Release number of selected component (if applicable):
1.7.1-3 or 0.9.7-4.2

How reproducible:
Every time

Steps to Reproduce:
1.Find an FC4 machine with foomatic-3.0.2-19 and hpijs-1.7.1-3 installed.
2.run up2date -u
  
Actual results:
up2date displays the error message given above and does nothing.

Expected results:
up2date should not complain and should update packages.

Additional info:
Comment 1 Tim Waugh 2006-01-08 05:42:00 EST

*** This bug has been marked as a duplicate of 177230 ***

Note You need to log in before you can comment on or make changes to this bug.