Bug 177230 - foomatic conflicts with hpijs-0.9.7-4.2
foomatic conflicts with hpijs-0.9.7-4.2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 177241 177600 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-07 19:05 EST by Jef Spaleta
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 07:17:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2006-01-07 19:05:25 EST
Description of problem:
hpijs-0.9.7-4.2  is in updates-release tree as of jan 5th

but the available foomatic-3.0.2-19 conflicts

rpm -q --conflicts foomatic
ghostscript < 7.05
hpijs < 1.5

previously hpijs was at version 1.7

foomatic needs an update published to prevent the conflict with the new hpijs
packages
Comment 1 Tim Waugh 2006-01-08 05:30:57 EST
*sigh*

This update was in testing for *months*, and no-one reported any problems.
Comment 2 Tim Waugh 2006-01-08 05:42:07 EST
*** Bug 177241 has been marked as a duplicate of this bug. ***
Comment 3 Jef Spaleta 2006-01-08 12:01:22 EST
I cant explain why testing didn't catch this... i was using testing and the
conflict didnt cause a problem.  Once someone else reported the problem in
#fedora I looked at my systems and the conflict was present but the conflict
didn't prevent the updates from happening.

-jef
Comment 4 J.Jansen 2006-01-09 03:44:31 EST
Got the problem on all my Fedora systems
Comment 5 don caldwell 2006-01-09 10:31:34 EST
the same class of comment appears on my system.
up fails with this complaint:

'Unresolvable chain of dependencies:
foomatic-3.0.2-19                        conflicts with hpijs < 1.5'

hpijs-1.7.1-3 is currently installed
Comment 6 J.Jansen 2006-01-11 03:25:02 EST
weird :
  I get the conflict when using up2date to update hpijs resulting in a failure
    to update hpijs
  but, when giving 
    yum install hpijs
  it installs fine and does not report the dependency.

       Jouk
Comment 7 Tim Waugh 2006-01-11 04:24:55 EST
Aha, that's why *I* didn't see the problem, at least.
Comment 8 Tim Waugh 2006-01-11 06:41:49 EST
Please enable the updates-testing repository in your up2date configuration, and
try the updated foomatic package from there:

https://www.redhat.com/archives/fedora-test-list/2006-January/msg00301.html

Does that fix the problem?
Comment 9 Seth Vidal 2006-01-11 13:31:30 EST
I wonder - does this have  anything to do, possibly, with an epoch/non-epoch'd
versioned conflict?
Comment 10 don caldwell 2006-01-11 13:42:47 EST
/usr/bin/yum update does indeed appear to solve my problem.
is up2date not up to date?
Comment 11 Tim Waugh 2006-01-12 06:31:22 EST
Please enable the updates-testing repository in your up2date configuration, and
try the updated foomatic package from there:

https://www.redhat.com/archives/fedora-test-list/2006-January/msg00301.html

Does that fix the problem?  The change is to add a '0' epoch to the conflict.
Comment 12 Tim Waugh 2006-01-12 06:37:06 EST
*** Bug 177600 has been marked as a duplicate of this bug. ***
Comment 13 John Guthrie 2006-01-12 10:36:35 EST
I just checked.  I updated to the foomatic in updates-testing via up2date. 
After that, I was able to update to the new hpijs using up2date just fine.  I
haven't actually tested the functionality of the new RPMS, but up2date seems to
work now.

Note You need to log in before you can comment on or make changes to this bug.