Bug 1772768 - Avoid creating pod on windows worker for openshift-marketplace
Summary: Avoid creating pod on windows worker for openshift-marketplace
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.2.z
Assignee: Daniel Sover
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On: 1775245
Blocks: 1775234
TreeView+ depends on / blocked
 
Reported: 2019-11-15 06:34 UTC by gaoshang
Modified: 2020-01-07 17:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1775234 1775245 (view as bug list)
Environment:
Last Closed: 2020-01-07 17:55:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-marketplace pull 272 'None' closed [release-4.2] Bug 1772768: Schedule registry pods onto linux nodes only 2020-05-20 03:04:48 UTC
Red Hat Product Errata RHBA-2020:0014 None None None 2020-01-07 17:55:23 UTC

Description gaoshang 2019-11-15 06:34:17 UTC
Description of problem:
After added a windows worker to OCP 4.2 GA cluster, openshift-marketplace was trying to create pod on windows worker and failed, this should be avoided.

Version-Release number of selected component (if applicable):
OCP 4.2 GA
# oc get clusterversion
NAME      VERSION   AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.2.0     True        False         27h     Cluster version is 4.2.0

How reproducible:
Always

Steps to Reproduce:
1. Install OCP 4.2 GA and add windows worker
2. Delete redhat-operators pod in openshift-marketplace(maybe more than once)
# oc delete pod redhat-operators-5d878dc498-c74s4 -n openshift-marketplace
pod "redhat-operators-5d878dc498-c74s4" deleted
3. Check redhat-operators pod was trying to create in windows worker and failed
# oc get pod -n openshift-marketplace
NAME                                    READY   STATUS              RESTARTS   AGE
certified-operators-6b5c9d69b8-mftww    1/1     Running             0          27h
community-operators-8b5c5bf9-fvww6      1/1     Running             0          27h
marketplace-operator-5c846b89cb-c79qs   1/1     Running             0          27h
redhat-operators-547f57b5b8-vfddz       1/1     Running             0          27h
redhat-operators-5d878dc498-kxvjv       0/1     ContainerCreating   0          123m
4. Check redhat-operators deployment, NodeSelector is not specified
# oc edit deployment.apps/redhat-operators

Actual results:
redhat-operators pod was trying to create in windows worker and failed.

Expected results:
Avoid creating pod on windows worker for openshift-marketplace.

Additional info:
This can be accomplished by adding a NodeSelector to all builds:
kubernetes.io/os: linux
Details please see: https://jira.coreos.com/browse/DEVEXP-341

Comment 2 Daniel Sover 2019-11-20 21:04:02 UTC

*** This bug has been marked as a duplicate of bug 1774752 ***

Comment 5 Fan Jia 2019-12-20 06:52:12 UTC
cv: 4.2.0-0.nightly-2019-12-19-211218

test result:
1. the spec of nodeSelector of opsrc deployment:     
 nodeSelector:
        beta.kubernetes.io/os: linux
2. delete the pods of opsrc the new pod won't be scheduled to the windows nodes.

Comment 7 errata-xmlrpc 2020-01-07 17:55:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0014


Note You need to log in before you can comment on or make changes to this bug.