Bug 1774752 - catalog source pods are scheduled onto windows nodes
Summary: catalog source pods are scheduled onto windows nodes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.2.z
Assignee: Daniel Sover
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On: 1773661
Blocks: 1775180
TreeView+ depends on / blocked
 
Reported: 2019-11-20 20:59 UTC by Daniel Sover
Modified: 2020-02-24 16:53 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1773661
: 1775180 (view as bug list)
Environment:
Last Closed: 2020-02-24 16:52:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1145 'None' closed [release-4.2] Bug 1774752: schedule catalogsource pods to linux nodes only 2020-03-19 01:01:01 UTC
Red Hat Product Errata RHBA-2020:0460 None None None 2020-02-24 16:52:59 UTC

Comment 1 Daniel Sover 2019-11-20 21:04:02 UTC
*** Bug 1772768 has been marked as a duplicate of this bug. ***

Comment 3 Jian Zhang 2019-11-22 07:39:14 UTC
Daniel,

Could you help add the fixed PR here? Thanks! Change status to ASSIGNED first.

Comment 7 Jian Zhang 2020-02-10 10:38:47 UTC
Cluster version is 4.2.0-0.nightly-2020-02-10-063139

mac:~ jianzhang$ oc exec catalog-operator-6f99d88468-9bxfq  -- olm --version
OLM version: 0.11.0
git commit: 79afb217828e7aa67a19399b7311b96c23f1ca1f


Now, the pods of the CatalogSource can only deploy in the nodes with the "beta.kubernetes.io/os: linux", LGTM, verify it!
mac:~ jianzhang$ oc get deployment  -o yaml |grep nodeSelector -A 2
        nodeSelector:
          beta.kubernetes.io/os: linux
        restartPolicy: Always
--
        nodeSelector:
          beta.kubernetes.io/os: linux
        restartPolicy: Always
--
        nodeSelector:
          node-role.kubernetes.io/master: ""
        priorityClassName: system-cluster-critical
--
        nodeSelector:
          beta.kubernetes.io/os: linux
        restartPolicy: Always


mac:~ jianzhang$ oc get catalogsource
NAME                  DISPLAY               TYPE   PUBLISHER   AGE
certified-operators   Certified Operators   grpc   Red Hat     20m
community-operators   Community Operators   grpc   Red Hat     20m
redhat-operators      Red Hat Operators     grpc   Red Hat     20m

mac:~ jianzhang$ oc get deployment 
NAME                   READY   UP-TO-DATE   AVAILABLE   AGE
certified-operators    1/1     1            1           20m
community-operators    1/1     1            1           20m
marketplace-operator   1/1     1            1           26m
redhat-operators       1/1     1            1           20m

Comment 9 errata-xmlrpc 2020-02-24 16:52:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0460


Note You need to log in before you can comment on or make changes to this bug.