Bug 1772942 - oc adm catalog image build `--manifest-dir` option ignored
Summary: oc adm catalog image build `--manifest-dir` option ignored
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Nick Hale
QA Contact: zhou ying
URL:
Whiteboard:
: 1775527 (view as bug list)
Depends On:
Blocks: 1779675
TreeView+ depends on / blocked
 
Reported: 2019-11-15 16:36 UTC by Nick Hale
Modified: 2020-05-04 11:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1779675 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:15:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 181 'None' closed Bug 1772942: Fix ignored `--manifest-dir` option in `oc adm catalog build` 2020-04-29 15:24:25 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:16:14 UTC

Comment 1 Nick Hale 2019-12-05 14:26:25 UTC
*** Bug 1775527 has been marked as a duplicate of this bug. ***

Comment 3 zhou ying 2019-12-19 05:27:44 UTC
Confirmed with latest oc client, the issue has fixed:
[root@dhcp-140-138 ~]# oc version -o yaml 
clientVersion:
  buildDate: "2019-12-19T01:27:23Z"
  compiler: gc
  gitCommit: 39b030d82916dd40377b421956da100d8ff557fd
  gitTreeState: clean
  gitVersion: v4.4.0
  goVersion: go1.12.12
  major: ""
  minor: ""
  platform: linux/amd64

Comment 6 Erik Nelson 2020-03-05 11:24:31 UTC
@Nick, 4.3.5, specifically:

clientVersion:       
  buildDate: "2020-02-28T07:04:58Z"
  compiler: gc
  gitCommit: c25fb9c7db26b5aaf123a9da0b8fc9f95b2dff92
  gitTreeState: clean
  gitVersion: 4.3.5-202002280657-c25fb9c                       
  goVersion: go1.12.12                                                                                                         
  major: ""                  
  minor: ""          
  platform: linux/amd64

Comment 9 errata-xmlrpc 2020-05-04 11:15:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.