Bug 1772953 - Anaconda leaves server-with-gui installs in inconsistent state: "yum search" warns "nothing provides module(perl:5.26)" [NEEDINFO]
Summary: Anaconda leaves server-with-gui installs in inconsistent state: "yum search" ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: dnf
Version: 8.1
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: rc
: 8.0
Assignee: Jaroslav Mracek
QA Contact: Radek Bíba
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-15 16:57 UTC by Mason Loring Bliss
Modified: 2020-04-28 16:49 UTC (History)
8 users (show)

Fixed In Version: libdnf-0.38.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:49:06 UTC
Type: Bug
Target Upstream Version:
mbanas: needinfo? (jblazek)


Attachments (Terms of Use)
Error from customer system (38.20 KB, image/png)
2019-11-15 16:57 UTC, Mason Loring Bliss
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1823 None None None 2020-04-28 16:49:17 UTC

Description Mason Loring Bliss 2019-11-15 16:57:37 UTC
Created attachment 1636579 [details]
Error from customer system

Description of problem:

After fresh install, dnf/yum notes:

"nothing provides module(perl:5.26) needed by" both perl-DBD-SQLite and perl-DBI

Version-Release number of selected component (if applicable):

8.1 ISO, with "server with gui"

How reproducible:


Steps to Reproduce:

1.  Download RHEL 8.1 ISO
2.  Launch KVM manager
3.  Create KVM server with the RHEL 8.1 ISO mounted  (RAM: 3027,  CPU: 2)
4.  Choose "Install.." grub menu item
5.  Disable kdump
6.  Change timezone to America/Chicago
7.  Add 5 additional NTP servers
8.  Disable default RH NTP server pool
9.  Under the "Purpose" section select "RHEL Server" and whichever option includes the GUI
10. Go into partitioning manager section, but don't change anything (won't let you click "Begin installation" otherwise)
11. Click "Begin Installatoin"
12. Set root password, but do not create a user

Actual results:

Error messages as noted. Screenshot attached.

Expected results:

No error messages about missing Perl module.

Additional info:

Doesn't appear to affect minimal or server-not-with-gui. Exploring more and will note results.

Comment 1 Jiri Konecny 2019-11-18 13:12:13 UTC
This is most probably packaging problem of perl. Switching to perl for further triage.

Comment 3 Petr Pisar 2020-01-20 09:28:58 UTC
The image reads:

$ dnf seat atop
[...]
Problem 1: conflicting requests
 - nothing provides module(perl:5.26) needed by module perl-DBD-SQLite:1.58:8010020190322125518:073fa5fe-0.x86_64
Problem 2: conflicting requests
 - nothing provides module(perl:5.26) needed by module perl-DBI-1.641:8010020190322130042:16b3ab4d-0.x86_64
No matches found.

That means you are searching for "atop" package and you get two warnings about conflicting modules.

My observations:

(1) perl-DBD-SQLite:1.58:8010020190322125518:073fa5fe-0.x86_64 module build is included in RHEL-8.1, not in RHEL-8.0. Thus I conclude you have installed RHEL-8.1. I corrected the "Version" field of this bug report. This module build context requires perl:5.26 module stream.

(2) perl-DBI-1.641:8010020190322130042:16b3ab4d-0.x86_64 is the same case.

(3) The atop package indeed does not exist RHEL-8.1 and the search command rightfully fails.

So the only remaining issue is a warning about the missing per:5.26 module. I have few explanations:

(1) Either you have disabled perl:5.26. What does "yum module list perl" command display for you? If perl:5.26 is not disabled, it should display something like this:

 # yum --quiet module list perl
Red Hat Enterprise Linux 8.1.0 AppStream - x86_64
Name     Stream       Profiles                Summary                                     
perl     5.24         common [d], minimal     Practical Extraction and Report Language    
perl     5.26 [d]     common [d], minimal     Practical Extraction and Report Language    

(2) Your repository is missing perl:5.26 module. Do you use a mirror created with Satellite 5? It does not support modules correctly. You can check the module presence with:

# yum --quiet module info perl:5.26 
Name             : perl
Stream           : 5.26 [d][a]
Version          : 820181219174508
Context          : 9edba152
Architecture     : x86_64
Profiles         : common [d], minimal
Default profiles : common
Repo             : rhel-8.1.0-appstream
Summary          : Practical Extraction and Report Language
Description      : Perl is a high-level programming language with roots in C, sed, awk and shell scripting. Perl is good at handling processes and files, and is especially good at handling text. Perl's hallmarks are practicality and efficiency. While it is used to do a lot of different things, Perl's most common applications are system administration utilities and web programming.

(3) This is just a spurious warning like in bug #1666770 that looks ugly but does not hinder any other operation. Does the message actually prevents you from doing anything?

Comment 4 Petr Pisar 2020-01-20 09:33:38 UTC
Because perl:5.26 module is provided in RHEL 8.1, I believe this is not a bug in Perl packaging. Probably one of the discrepancies outlined above. Most probably a DNF or a mirroring tool glitch.

Comment 5 Jiri Konecny 2020-01-21 10:07:14 UTC
Hello,

The DNF team needs debug solver data from the transaction to properly debug this issue. Could you please start the installation with `inst.debug inst.nokill` on kernel command line, run the whole installation and then please attach all the logs from `/root/debugdata`. I guess the best way will be to tar the directory and upload it.

inst.debug = enable storing of debug solver data
inst.nokill = avoid rebooting when the installation finish

Comment 6 Jaroslav Mracek 2020-01-30 09:53:46 UTC
I am really sorry, but I was lost in reproducer. The issue is reproducible quite easily. 
1. Install RHEL server with GUI from iso 8.1.
2. Run dnf search <argument>

What happened. DNF doesn't have any data about enabled modules therefore it uses Fail-Safe data that unfortunately do not have perl:5.26 module stored.

The issue is resolved by https://github.com/rpm-software-management/libdnf/commit/baa53ce29a25f8789c523afb6f0c98d48092c8fa.

The report is similar to bz 1762314 but the reproducer is completely different. Therefore I do not consider it as a duplicate, because it requires an alternative testing and verification approach.

Comment 15 errata-xmlrpc 2020-04-28 16:49:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1823


Note You need to log in before you can comment on or make changes to this bug.