Bug 1773378 - python-zeep fails to build with Python 3.8 on Fedora 32+
Summary: python-zeep fails to build with Python 3.8 on Fedora 32+
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-zeep
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Georg Sauthoff
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1773371
Blocks: F32FTBFS F32FailsToInstall PYTHON38 1773379
TreeView+ depends on / blocked
 
Reported: 2019-11-17 23:20 UTC by Miro Hrončok
Modified: 2019-12-06 23:37 UTC (History)
1 user (show)

Fixed In Version: python-zeep-3.3.1-3.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-06 23:37:22 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2019-11-17 23:20:13 UTC
python-zeep fails to build with Python 3.8.0b4 in Fedora 32.

See the build failures at https://koji.fedoraproject.org/koji/search?match=glob&type=package&terms=python-zeep

DEBUG util.py:593:  Error: 
DEBUG util.py:593:   Problem: conflicting requests
DEBUG util.py:593:    - nothing provides python(abi) = 3.7 needed by python3-aioresponses-0.6.0-2.fc31.noarch
DEBUG util.py:593:    - nothing provides python3.7dist(aiohttp) >= 2 needed by python3-aioresponses-0.6.0-2.fc31.noarch
DEBUG util.py:593:    - nothing provides python3.7dist(aiohttp) < 4 needed by python3-aioresponses-0.6.0-2.fc31.noarch

It is not important whether the problem is caused by this package or another, this issue is blocking the Python 3.8 rebuild of this package.
If this package won't build with 3.8, it won't be installable, along with all its dependent packages, in Fedora 32 and further.

Furthermore, as it fails to install, its dependent packages will fail to install and/or build as well.

Please rebuild the package in Fedora 32 (rawhide).

Let us know here if you have any questions. Thank You!

Comment 1 Miro Hrončok 2019-11-25 10:28:15 UTC
What is the plan here? Do we try to keep the package or retire it?

Comment 2 Georg Sauthoff 2019-11-26 16:21:48 UTC
I definitely want to keep it since it provides a convenient way to access WSDL web-services - such as the services the python-inema package is interacting with.

I suggest to approach this from the practical side: temporarily disable the zeep tests that depend on python-aioresponses until either python-aioresponses fixed their Python 3.8 support or python-zeep migrates to something else.

I can implement this approach next week at the earliest.

Comment 3 Miro Hrončok 2019-11-26 16:23:14 UTC
Sounds reasonable.


Note You need to log in before you can comment on or make changes to this bug.