Bug 1773379 - python-inema fails to build with Python 3.8 on Fedora 32+
Summary: python-inema fails to build with Python 3.8 on Fedora 32+
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-inema
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Georg Sauthoff
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1773378
Blocks: F32FTBFS F32FailsToInstall PYTHON38
TreeView+ depends on / blocked
 
Reported: 2019-11-17 23:20 UTC by Miro Hrončok
Modified: 2019-12-06 23:41 UTC (History)
1 user (show)

Fixed In Version: python-inema-0.8-3.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-06 23:41:57 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2019-11-17 23:20:30 UTC
python-inema fails to build with Python 3.8.0b4 in Fedora 32.

See the build failures at https://koji.fedoraproject.org/koji/search?match=glob&type=package&terms=python-inema

DEBUG util.py:593:  Error: 
DEBUG util.py:593:   Problem: conflicting requests
DEBUG util.py:593:    - nothing provides python3.7dist(attrs) >= 17.2 needed by python3-zeep-3.3.1-2.fc31.noarch
DEBUG util.py:593:    - nothing provides python3.7dist(cached-property) >= 1.3 needed by python3-zeep-3.3.1-2.fc31.noarch
DEBUG util.py:593:    - nothing provides python3.7dist(defusedxml) >= 0.4.1 needed by python3-zeep-3.3.1-2.fc31.noarch
DEBUG util.py:593:    - nothing provides python3.7dist(lxml) >= 3.1 needed by python3-zeep-3.3.1-2.fc31.noarch
DEBUG util.py:593:    - nothing provides python3.7dist(requests) >= 2.7 needed by python3-zeep-3.3.1-2.fc31.noarch
DEBUG util.py:593:    - nothing provides python3.7dist(requests-toolbelt) >= 0.7.1 needed by python3-zeep-3.3.1-2.fc31.noarch
DEBUG util.py:593:    - nothing provides python3.7dist(pytz) needed by python3-zeep-3.3.1-2.fc31.noarch
DEBUG util.py:593:    - nothing provides python(abi) = 3.7 needed by python3-zeep-3.3.1-2.fc31.noarch
DEBUG util.py:593:    - nothing provides python3.7dist(six) >= 1.9 needed by python3-zeep-3.3.1-2.fc31.noarch
DEBUG util.py:593:    - nothing provides python3.7dist(isodate) >= 0.5.4 needed by python3-zeep-3.3.1-2.fc31.noarch
DEBUG util.py:593:    - nothing provides python3.7dist(appdirs) >= 1.4 needed by python3-zeep-3.3.1-2.fc31.noarch

It is not important whether the problem is caused by this package or another, this issue is blocking the Python 3.8 rebuild of this package.
If this package won't build with 3.8, it won't be installable, along with all its dependent packages, in Fedora 32 and further.

Furthermore, as it fails to install, its dependent packages will fail to install and/or build as well.

Please rebuild the package in Fedora 32 (rawhide).

Let us know here if you have any questions. Thank You!

Comment 1 Miro Hrončok 2019-11-25 10:28:23 UTC
What is the plan here? Do we try to keep the package or retire it?

Comment 2 Georg Sauthoff 2019-11-26 16:25:31 UTC
I definitely want to keep it.

Plan is to apply a fix to zeep: https://bugzilla.redhat.com/show_bug.cgi?id=1773378#c2


Note You need to log in before you can comment on or make changes to this bug.