Bug 177362 - XKB map for keyboard cz and variant qwerty does not work
XKB map for keyboard cz and variant qwerty does not work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-xkbdata (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
: 178892 (view as bug list)
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2006-01-09 21:15 EST by Milan Kerslager
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 06:06:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 5077 None None None Never

  None (edit)
Description Milan Kerslager 2006-01-09 21:15:15 EST
I have FC5 test1 and I tryed to update to the latest development tree. When I'm
trying to use czech keyboard mapping, the error occur with a question to report
this bug. Error when trying to activate XKB settings:

# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us,cz_qwerty", ",",
"grp:shift_toggle,grp_led:scroll,grp:switch"
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us,cz_qwerty", "",
"grp:shift_toggle,grp_led:scroll,grp:switch"

# gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [us,cz       qwerty]
 model =
 overrideSettings = true
 options = []
Comment 1 Milan Kerslager 2006-01-10 20:00:01 EST
I tryed today updates with no luck (I added Czechia qwerty keyboard mappings
from the keymap applet inside Gnome). This is the output of the error message:

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
69999904

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
Comment 2 Milan Kerslager 2006-01-14 12:10:16 EST
I updated FC5 test1 machine today with no luck again. When trying to add
'Czechia/qwerty' keymap, the same error occur still. Some keymaps works though.
Comment 3 Milan Kerslager 2006-01-21 16:26:19 EST
In FC5test2 I see Czech keyobard as active in the XKB applet (in Gnome) after
the install, but the keymap is actually English. When trying to put second
keymap to the XKB config (through XKB applet in Gnome), the same error occur as
I wrote above about FCtest1. I see an error when trying to use 'setxkbmap cs' on
the command line.
I'm not able to update to the latest devel tree as there is some inconsitency on
the FC download server (I commented out the mirror list and tryed to update from
the main FC server).
Comment 4 Mike A. Harris 2006-01-31 13:52:55 EST
*** Bug 178892 has been marked as a duplicate of this bug. ***
Comment 5 Milan Kerslager 2006-02-01 08:44:40 EST
I found that control-center (latest 2.13.90-1 has been builded at Jan 30) is
incorrectly trying to set Czech keymap to 'cs*' even the names of keymaps in
X.org has been updated to 'cz*'. This is correct as 'cs' is historic relict and
we are using 'cz' for our language for more than one decade. Please fix or
regenerate appropriate keymap table in control-center application. Thank you.

This is possible that Anaconda has the same problem too...
Comment 6 Milan Kerslager 2006-02-01 08:52:35 EST
The cz_qwerty variant does not work even cz keymap works. Sorry for the mistake.
The control-center is correct... Changing component to xorg-x11-xkbdata-1.0.1-1.
Comment 7 Mike A. Harris 2006-02-01 18:37:33 EST
I believe you need to specify the layout as cz, and the variant as querty
for this to work in X11R7.
Comment 8 Sergey V. Udaltsov 2006-02-01 18:49:24 EST
Yes it is now cz(qwerty). But I will probably add the compatibility rule for
cz_qwerty. Just to reduce further bug reports.
Comment 9 Mike A. Harris 2006-02-01 22:57:07 EST
Each person experiencing this problem, please try the following:

setxkbmap -rules xorg -layout cz(qwerty)

Report back any success or errors.

TIA
Comment 10 Milan Kerslager 2006-02-02 07:05:53 EST
This does not work:

# setxkbmap -rules xorg -layout 'cz(qwerty)'
Error loading new keyboard description
# setxkbmap -rules xorg -layout cz -variant qwerty
Error loading new keyboard description
# setxkbmap -rules xorg -layout cz
# (only the last command above works)
Comment 11 Milan Kerslager 2006-02-05 14:38:16 EST
Changing summary to match current problem.
Comment 12 Milan Kerslager 2006-02-19 17:52:11 EST
I updated to the current devel tree (ie mostly FC5test3) but layout cz variant
qwerty still does not work.
Comment 13 Libor Vanek 2006-02-20 06:27:57 EST
I can confirm that - I also run "yum update" last week, czech keyboard is
working BUT only in "basic" layout - not in the "bksl", "qwerty" or "qwerty_bksl".
Comment 14 Miloslav Trmač 2006-02-20 13:21:07 EST
See xorg bug 5077.  The patch
(https://bugs.freedesktop.org/attachment.cgi?id=3824) fixes the other cz layouts.
Comment 15 Mike A. Harris 2006-02-21 05:35:53 EST
Proper URL for reference:

https://bugs.freedesktop.org/show_bug.cgi?id=5077
Comment 16 Milan Kerslager 2006-02-21 16:50:01 EST
Confirming the patch is working. Please include as bugfix before FC5 gold release.

However, there is another problem with gnome-keyboard-properties (from package
control-center-2.13.92-2) because there is very few modifiers available (to
switch keymaps etc). See bug #178163 for more info.
Comment 17 Mike A. Harris 2006-02-21 20:46:52 EST
Resolved in rawhide xorg-x11-xkbdata-1.0.1-3
Comment 18 Miloslav Trmač 2006-02-22 18:49:19 EST
Not really: the patch is in CVS, but not applied in the spec file.
Comment 19 Milan Kerslager 2006-02-23 08:51:34 EST
Confirming that xorg-x11-xkbdata-1.0.1-3 does not contain the patch...
Comment 20 Mike A. Harris 2006-02-24 06:06:54 EST
Doh.  Fixed in xorg-x11-xkbdata-1.0.1-4

Note You need to log in before you can comment on or make changes to this bug.