Bug 178163 - libxklavier-2.1-3.2 makes XKB layout options unaccessible
libxklavier-2.1-3.2 makes XKB layout options unaccessible
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libxklavier (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
:
: 183055 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-18 00:46 EST by Brian G. Anderson
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-14 12:57:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2006-01-18 00:46:39 EST
Description of problem:
The "Layout Options" tab in gnome-keyboard-preferences only has one keyboard
option "Miscellaneious compatability options".  All other options, such as "Make
caps lock additional control key", are absent.


Version-Release number of selected component (if applicable):
2.13.4-2


How reproducible:
everytime


Steps to Reproduce:
1. fresh install of FC5T2 with updates to 1/17/06
2. use gnome-keyboard-properties
3.
  
Actual results:
Keyboard options such as swap control key and caps lock, not present in window.


Expected results:
more options


Additional info:
Comment 1 Rahul Sundaram 2006-02-20 06:34:56 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Milan Kerslager 2006-02-21 16:48:01 EST
I have FC5test3 updated against actual development repository (see the time of
this comment). However, the bug is still here so I'm reopenning this bug.

As I'm unable to set how to swicth keymaps, this is a real bug. GUI is almost
unusable because this.
Comment 3 Milan Kerslager 2006-02-21 16:51:36 EST
Sorry - broken gnome-keyboard-properties is from package control-center-2.13.92-2.
Comment 4 Jiri Cerny 2006-02-22 12:47:53 EST
This bug is actually not problem of control-center but of libxklavier. It has
been  fixed upstream (revision 1.15 of
/libxklavier/libxklavier/xklavier_config.c in libklavier fd.o cvs --- handling
XML comments) at least one month ago. 
Comment 5 Milan Kerslager 2006-02-23 08:59:38 EST
Changing component to libxklavier, changing summary to match the problem.
Current devel version is libxklavier-2.1-3.2 and contains the bug.

Please apply the fix. Thank you.
Comment 6 Mike A. Harris 2006-02-25 15:45:59 EST
*** Bug 183055 has been marked as a duplicate of this bug. ***
Comment 7 Milan Kerslager 2006-02-27 21:42:13 EST
The patch can be found here:
http://bugs.debian.org/cgi-bin/bugreport.cgi/XklReadConfigItem_parse_comments.patch?bug=336791;msg=40;att=1

This bug has been fixed in linxklavier 2.0 but reappeared in 2.1, see the bug
report for Debian unstable (package libxklavier10):
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=336791
Comment 8 Milan Kerslager 2006-02-27 22:16:51 EST
The patch is working. You may try my rebuilded packages from:
ftp://ftp.pslib.cz/pub/users/Milan.Kerslager/Fedora-5/

The CVS tree on http://sourceforge.net/cvs/?group_id=319 is outdated (or dead?)
so this seems like the patch must be included in the FC5 package itself. I'm not
sure where the comments #4 come from. Is there another CVS tree for libxklavier?

Please fix this before FC5-final. This is one-liner and this bug makes all
national keymaps unusable (ie keymaps groups can't be switched by configuring
hotkeys with GNOME keyboard applet and most of all other keymaps options are
unaccessible too).

Trying to raise Priority of this bug to high (do you agree Mike?).
Comment 9 Milan Kerslager 2006-03-04 08:16:36 EST
Anybody able to confirm the fix/RPM is working? The bug is not yet fixed :-(
Comment 10 Miloslav Trmač 2006-03-04 09:19:02 EST
AFAICS the layout options are back with xorg-x11-xkbdata-1.0.1-6
(using libxklavier-2.1-3.2).
Comment 11 Milan Kerslager 2006-03-05 10:58:10 EST
I tryed the patched libxklavier from comment #8 with old xorg-x11-xkbdata with
no luck. The patch is not working :-( New xorg-x11-xkbdata-1.0.1-6 solves the
problem.

This seems like a real bug in libxklavier and the workaround is not a final
solution IMHO. The bug could be closed for now as RAWHIDE.
Comment 12 Milan Kerslager 2006-03-14 12:57:04 EST
New try to close this bug:

The patch from comment #8 is working. I tryed xorg-x11-xkbdata-1.0.1-2 from
release of FC5test3 (cz keyboard needs additional fix from bug #177362).

The current devel tree contains libxklavier-2.1.0.2006.02.23-2 and
xorg-x11-xkbdata-1.0.1-7 and everything seems to work.

So closing the bug. If you experience the problem, please reopen.

Note You need to log in before you can comment on or make changes to this bug.