Bug 1773661 - catalog source pods are scheduled onto windows nodes
Summary: catalog source pods are scheduled onto windows nodes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: Daniel Sover
QA Contact: Salvatore Colangelo
URL:
Whiteboard:
Depends On:
Blocks: 1774752 1775180
TreeView+ depends on / blocked
 
Reported: 2019-11-18 16:39 UTC by Daniel Sover
Modified: 2020-01-23 11:13 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1774752 (view as bug list)
Environment:
Last Closed: 2020-01-23 11:13:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1132 'None' closed Bug 1773661: schedule catalogsource pods to linux nodes only 2020-04-05 22:43:54 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:13:26 UTC

Description Daniel Sover 2019-11-18 16:39:26 UTC
Description of problem:
Customer raised a github issue noting that the operatorhubio pod was scheduled onto a windows node in a split linux/windows cluster. See https://github.com/operator-framework/operator-lifecycle-manager/issues/1119 for full description.

Since catalog sources are compiled for linux the pod fails to start on the windows VM. As we see more mixed clusters this bug will become more common.  


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create catalog source pods in a mixed OS cluster
2. Since there is no node selector for catalog source pods, some will eventually end up on windows VMs and fail to start. 
3.

Actual results:
Pod ends up on windows VM and fails to start

Expected results:
Pod is always scheduled to a linux VM like other OLM-related pods

Additional info:

Comment 5 errata-xmlrpc 2020-01-23 11:13:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.