Bug 177379 - need Oriya more input maps
Summary: need Oriya more input maps
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: m17n-db (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mayank Jain
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature, i18n
Depends On:
Blocks: Indic
TreeView+ depends on / blocked
 
Reported: 2006-01-10 06:12 UTC by Jens Petersen
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: m17n-db-1.3.3-7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-07 12:10:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Oriya inscript keymap (2.40 KB, application/octet-stream)
2006-06-02 12:29 UTC, Mayank Jain
no flags Details

Description Jens Petersen 2006-01-10 06:12:05 UTC
Description of problem:
An inscript map for Oriya needs to be added.

Additional info:
There is a layout in http://tdil.mit.gov.in/keyoverlay.htm
and typewriter layouts in
http://indlinux.sourceforge.net/images/keymap/typ/

Comment 1 Jens Petersen 2006-02-22 09:56:09 UTC
m17n-db includes an itrans map.

Comment 2 Mayank Jain 2006-03-24 06:47:34 UTC
While creating the keymap, a problem looking very similar to bug #129541 is
coming up. This happens for certain lines only (& consistantly for them).
Problems faced in gedit & yudit, both.

Comment 3 Mayank Jain 2006-03-28 14:01:31 UTC
sbehera,
Kindly check if this inscript keymap works fine & is according to the standards...
http://oriya.sarovar.org/download/keymaps/Oriya-Inscript.kmap.gz

Related link - http://oriya.sarovar.org/docs/getting_started/

Comment 4 subhransu behera 2006-03-29 11:28:38 UTC
I have checked with this link. It is not a scim format. In this script the
author has only written how to pronounce the alphabate in a particular key. Or
else we can say it is just a character representation.

Comment 5 subhransu behera 2006-03-29 11:32:58 UTC
While trying to create the or-inscript.mim the double quotes are changing into
single quotes. The problem remain unchanged even if I tried the write with
raw-codes. 

Comment 6 Jens Petersen 2006-03-29 16:03:06 UTC
Subhransu, you need to quote "double quote" with backslash like this:

  "\""

similarly backslash needs to be quoted too:

  "\\"

in the .mim file.  Hope that helps.


Comment 7 subhransu behera 2006-03-31 08:20:46 UTC
Jens, There is a oriya chracter "ଠ" in the position of "double quote".

So, it can't be quoted.

How ever, I tried to quote the backslash as mentioned by you above. 

But the problem is unchanged.

Comment 8 Mayank Jain 2006-06-02 12:29:48 UTC
Created attachment 130399 [details]
Oriya inscript keymap

Comment 9 Mayank Jain 2006-06-02 12:54:41 UTC
Build sent to rawhide.

Comment 10 Satyabrata Maitra 2006-06-07 12:10:36 UTC
Inscript keymap in Oriya(or_IN is now available in m17n-db library. As the
primary purpose of creating this bug has been solved, So I am closing this bug. 

I think, for tracking of individual keymap unavailablily or the status of
availability of those in Oriya, it would be better to create different bug. So,
my concern is to open a new bug for typewriter keymap in oriya language.


Note You need to log in before you can comment on or make changes to this bug.