Bug 177443 - GDM won't find config file, Xkeeps crashing, could not access configuration key
GDM won't find config file, Xkeeps crashing, could not access configuration key
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-01-10 14:09 EST by Kevin Verma
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-16 12:36:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdm messages (295.11 KB, text/plain)
2006-01-11 19:28 EST, Clyde E. Kunkel
no flags Details
gdm.conf file as requested (22.95 KB, text/plain)
2006-01-13 17:27 EST, Clyde E. Kunkel
no flags Details
1/14/06 rawhide gdm custom.conf file (22.90 KB, text/plain)
2006-01-14 14:28 EST, Clyde E. Kunkel
no flags Details

  None (edit)
Description Kevin Verma 2006-01-10 14:09:31 EST
Description of problem:
GDM update gdm-2.13.0.4-2, seems to have mutiple issues, as first of all no
configuration file is found, second it keeps crashing, third gdmsetup won't run.
I have setup debug in config file by hand to true, but I am not getting any
logs, please suggest how should I debug the same for you further.

How reproducible:
Always

Steps to Reproduce:
I had just updated my FC5 devel with yum, and I noticed that GDM is not running,
a quick ps |aux shows me as bellow:
[server1:~] # ps aux |grep gdm
root      2411  0.0  0.7  12408  2696 ?        S    Jan10   0:00
/usr/sbin/gdm-binary -nodaemon
root      4845  0.0  0.3   4376  1176 ?        Ss   00:27   0:00 /bin/sh
/etc/X11/gdm/XKeepsCrashing
root      4862  0.0  0.0   1528   372 ?        S    00:27   0:00
/usr/libexec/gdmopen -l /bin/sh -c /etc/X11/gdm/XKeepsCrashing -noopen
root      4863  0.0  0.3   4372  1180 tty7     Ss+  00:27   0:00 /bin/sh
/etc/X11/gdm/XKeepsCrashing -noopen
root      5177  0.0  0.1   3860   700 pts/1    R+   00:36   0:00 grep gdm

FC5 devel at my site is on a remote server. I tried running the gdmsetup again:
[server1:~] # DISPLAY=192.168.0.1:0 /usr/sbin/gdmsetup
Could not access GDM configuration file.

I restored the previous config file which was preserved as gdm.conf.rpmsave, as
gdm.conf and tried running the setup again:
DISPLAY=192.168.0.1:0 /usr/sbin/gdmsetup
Could not access configuration key daemon/Greeter=/usr/libexec/gdmlogin
Segmentation fault

Version-Release number of selected component (if applicable):
gdm-2.13.0.4-2



  
Actual results:
GDM is not accessible, gdmsetup just won't run

Expected results:
GDM is avaialble for login, or GDMsetup should run as commanded.

Additional info:
Comment 1 Kevin Verma 2006-01-11 09:24:05 EST
Its the second day since this update and the server is now rebooted first time
after updates. GDM is working fine, perhaps maintainer may ignore the bug report
for a while, unless I observe another issue related to main report. 

Thanks,
Comment 2 Clyde E. Kunkel 2006-01-11 19:28:47 EST
Created attachment 123100 [details]
gdm messages

Gdm constantly restarted after rawhide update of 10 Jan on two separate rawhide
installations.	had to revert to 2.8.0.4-13.1 to return to normal operations. 
Attached file are from cat /var/log/messages | grep gdm > gdm-msg.txt.	Will
use --exclude=gdm until new version is out.
Comment 3 Ray Strode [halfline] 2006-01-11 23:00:52 EST
Ahh, that's not good.

Can you attach your /etc/X11/gdm/custom.conf file?
Comment 4 Clyde E. Kunkel 2006-01-13 17:27:40 EST
Created attachment 123181 [details]
gdm.conf file as requested

Sorry for the delay, I forgot to check the Cc box.  I don't have a custom.gdm
file but I am attaching what I believe was the gdm file that was in effect when
the update occurred.  It was gdm.conf~ which I renamed just now.  I did have a
custom setting in it:  I had the logon dialogue box pinned to the 0,0 position
of the screen.	I notice that when I reverted gdm, a new gdm.conf was created. 
HTH.
Comment 5 Wart 2006-01-14 01:19:31 EST
I was having a similar problem with gdm restarting and falling back to the
default chooser when it had problems with the config file.  I found there were
some invalid entries in /usr/share/gdm/config/gdm.conf-custom:

line 48:
Greeter=/usr/bin/gdmgreeter
should be
Greeter=/usr/libexec/gdmgreeter

There were also a number of places where gdm.conf-custom referred to the old
path to the X binary in /usr/X11R6/bin/X.  It should instead be /usr/bin/X.

Once I fixed these paths gdm seemed to function better.  The only problem was
that I could no longer get it to load the gnome session anymore; it kept dumping
me to the failsafe session.  I'm still looking into that one.
Comment 6 Clyde E. Kunkel 2006-01-14 14:28:25 EST
Created attachment 123204 [details]
1/14/06 rawhide gdm custom.conf file

Todays rawhide (1/14/06) gdm did not fix the problem.  Very same symptons. 
Attached is the custom.conf file.
Comment 7 Russell Coker 2006-01-16 07:34:46 EST
I have a similar problem.  On my rawhide system both gdmgreeter and gdmlogin 
SEGV, and in both cases they SEGV immediately after the system call 
access("/var/gdm/.fonts", X_OK) = -1 ENOENT (No such file or directory) 
 
I learned this through "strace -ff gdm".  Do you know of a way of launching 
gdb on the gdmgreeter or gdmlogin process or getting a core file so that I can 
learn more? 
Comment 8 Ray Strode [halfline] 2006-01-16 11:18:10 EST
Sounds like SELinux might not be allowing fontconfig to write cache files in
/var/gdm (gdm's home dir).

if you export DOING_GDM_DEVELOPMENT=1 you can run /usr/libexec/gdmgreeter from
the terminal (it won't do authentication but the gui bits will start up). 
Otherwise you can gdb attach to the process while it's running.
Comment 9 Ray Strode [halfline] 2006-01-16 11:45:35 EST
Regarding comment 5,

I tried to make some effort to migrate a users existing settings over from there
existing gdm.conf into the new gdm.conf-custom file available in the latest
release of gdm.  Some settings shouldn't get migrated though, they should just
get filtered out.

I'll look into it.
Comment 10 Clyde E. Kunkel 2006-01-16 12:16:25 EST
Fresh install of FC5T2, problem pops up **AFTER** changing greeter to gtk from
themed. (I think it was gtk. After I reverted to 2.8.0.4-13.1, the old gdmsetup
was present, and so couldn't check.  Anyway, switching from the default seems to
have caused the problem....).  No custom.conf file, guess it gets blown away
when you revert gdm.
Comment 11 Ray Strode [halfline] 2006-01-16 12:35:26 EST
Users who upgrade from gdm 2.8 to gdm 2.13 should get better migration of their
settings in tomorrow's rawhide.

If you've already upgraded, your system is broke, and you don't want to
downgrade and reupgrade, you can work around the problem by deleting
/usr/share/gdm/config/gdm.conf-custom.

I'm going to close the bug, but if anyone has anymore problems going from gdm
2.8 to 2.13, please reopen.
Comment 12 Wart 2006-01-16 12:47:06 EST
> If you've already upgraded, your system is broke, and you don't want to
> downgrade and reupgrade, you can work around the problem by deleting
> /usr/share/gdm/config/gdm.conf-custom.
> 
> I'm going to close the bug, but if anyone has anymore problems going from gdm
> 2.8 to 2.13, please reopen.

Deleting gdm-conf.custom fixed my current rawhide install.  I'll try another
upgrade from FC-4 -> Rawhide when the next package is released.
Comment 13 Clyde E. Kunkel 2006-01-17 12:03:14 EST
Ok, its still broken, please reopen this bug.

Step-by-step:

1. Upgrade gdm to gdm-2.13.0.4-4
2. reboot
3. logon as root ok, except kde session instead of default gnome session came up.
3. using menu, modify gdm (btw, I really like the new gdmsetup gui) to use plain
with face browser.
4. logoff
5. new greeter comes up, select gnome session, logon as root.  All ok.
6. using menu, modify gdm to enable logging, allow tcp forwarding.  Logoff
7. logon as root, all ok.
8. using menu, modify gdm to add user kunkelc for face browser.  Logoff
9. problem starts now, gdm tries 6 times, then quits for 2 minutes.  Use time to
logon as root and delete user kunkelc from gdm.conf-custom.  Reboot
10. can now logon again without gdm probs
Comment 14 Ray Strode [halfline] 2006-01-17 12:56:40 EST
Hi Clyde,

This sounds like it may be a different issue.

Could you file a new bug report with a summary that's something like

"gdm doesn't crashes after adding user to face browser include list"

and copy and paste your step by step message.

if you could provide a pointer to the new bug report here for others to be able
to follow along, that'd be great, too

Thanks
Comment 15 Clyde E. Kunkel 2006-01-17 15:58:04 EST
OK, bug 178115 opened.  Thanks for chasing this.

Note You need to log in before you can comment on or make changes to this bug.