Bug 1774621 - OLM CSV Metrics are not present in Telemeter
Summary: OLM CSV Metrics are not present in Telemeter
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Alexander Greene
QA Contact: Bruno Andrade
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-20 14:56 UTC by Alexander Greene
Modified: 2020-05-04 11:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1776935 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:16:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 561 'None' closed Bug 1774621: Bump telemeter-client 2020-06-03 17:34:04 UTC
Github openshift cluster-monitoring-operator pull 563 'None' closed Bug 1774621: telemeter: bump dependencies 2020-06-03 17:34:04 UTC
Github openshift telemeter pull 253 'None' closed Bug 1774621: Add OLM CSV metrics 2020-06-03 17:34:04 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:16:42 UTC

Description Alexander Greene 2019-11-20 14:56:45 UTC
Description of problem:
Telemeter does not whitelist `csv_succeeded` and `csv_abnormal` metrics.

Version-Release number of selected component (if applicable):
4.3.0

How reproducible:
Always

Steps to Reproduce:
1. Visit Telemeter: https://telemeter-lts-dashboards.datahub.redhat.com/explore
2. Make a query for `csv_succeeded` or `csv_abnormal`

Actual results:
No results.

Expected results:
Lots of results.

Comment 2 Bruno Andrade 2019-11-21 22:25:14 UTC
Tested on 4.3.0-0.nightly-2019-11-21-122827, but as shown on http://pics.osci.redhat.com/7s2wpw.png , cluster metrics are not being collected. Talked with Alex and he told me that there are some steps to whitelist these metrics collect at telemeter that is being worked at openshift/cluster-monitoring-operator/pull/561 PR.

Comment 7 Alexander Greene 2019-12-04 10:27:29 UTC
> The metric is whitelisted in 4.4 (https://github.com/openshift/cluster-monitoring-operator/pull/563) and 4.4 (https://github.com/openshift/cluster-monitoring-operator/pull/570) on client-side. I guess what is missing is whitelisting them on server-side which is not tracked in Bugzilla. Please follow steps 7. and 8. of the Telemetry guide: https://docs.google.com/document/d/1a6n5iBGM2QaIQRg9Lw4-Npj6QY9--Hpx3XYut-BrUSY

I am pushing these changes through - I will update the ticket once it is ready to test.

Comment 8 Bruno Andrade 2019-12-13 16:48:05 UTC
Installed an Operator with a wrong OperatorGroup and after that did a correction to Operator installation succeed. I was able to see this behavior metrics by querying telemeter:

csv_abnormal{_id="6724cdfd-e9e7-49fb-99f7-a3b1dc09981b",endpoint="https-metrics",exported_namespace="test-operators",instance="10.130.0.18:8081",job="olm-operator-metrics",name="etcdoperator.v0.9.2",namespace="openshift-operator-lifecycle-manager",phase="Failed",pod="olm-operator-7d9d75f4f9-6vt46",prometheus="openshift-monitoring/k8s",reason="UnsupportedOperatorGroup",receive="true",service="olm-operator-metrics",version="0.9.2"}


csv_succeeded{_id="6724cdfd-e9e7-49fb-99f7-a3b1dc09981b",endpoint="https-metrics",exported_namespace="test-operators",instance="10.130.0.18:8081",job="olm-operator-metrics",name="etcdoperator.v0.9.2",namespace="openshift-operator-lifecycle-manager",pod="olm-operator-7d9d75f4f9-6vt46",prometheus="openshift-monitoring/k8s",receive="true",service="olm-operator-metrics",version="0.9.2"}

Considering that, marking as VERIFIED.

Cluster Version: 4.4.0-0.nightly-2019-12-11-234322

Comment 11 errata-xmlrpc 2020-05-04 11:16:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.