Bug 1774926 - Unable to install package
Summary: Unable to install package
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: BackupPC
Version: epel8
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1780700 1780702 1780704 1789003
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-21 09:56 UTC by Marcin Trendota
Modified: 2020-02-18 13:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-19 16:49:59 UTC
Type: Bug


Attachments (Terms of Use)

Description Marcin Trendota 2019-11-21 09:56:36 UTC
I'm unable to install BackupPC:

Problem: conflicting requests
  - nothing provides par2cmdline needed by BackupPC-4.3.1-2.el8.x86_64
  - nothing provides perl(Net::FTP::AutoReconnect) needed by BackupPC-4.3.1-2.el8.x86_64
  - nothing provides perl(Net::FTP::RetrHandle) needed by BackupPC-4.3.1-2.el8.x86_64
  - nothing provides perl(XML::RSS) needed by BackupPC-4.3.1-2.el8.x86_64

I was able to compile these packages from EPEL7, except for last one.

Comment 1 Richard Shaw 2019-11-21 13:48:21 UTC
EPEL 8 is still very much a work in progress. As you've noted there's still some dependencies that have not made it in. I would recommend that you file a bug for each one to request an EPEL 8 package be supported. I may do so when I have time but I'm fighting much bigger issues with Python 2 being removed from Fedora and the current disaster that if FreeCAD on Fedora.

Comment 2 Richard Shaw 2019-12-06 16:54:02 UTC
perl-xml-rss is in testing.

Comment 3 Richard Shaw 2020-01-05 00:12:16 UTC
It looks like all the dependencies should now be available. Can to try to install now and report back if you are successful?

Comment 4 Marcin Trendota 2020-01-08 10:36:19 UTC
Sorry for delay.

Looks different now:

 Problem: package BackupPC-4.3.1-3.el8.x86_64 requires perl(XML::RSS), but none of the providers can be installed
  - conflicting requests
  - nothing provides perl(DateTime::Format::Mail) needed by perl-XML-RSS-1.61-1.el8.noarch

Comment 5 Richard Shaw 2020-01-08 16:08:38 UTC
Looks like you need to install the PowerTools repo as well per:

https://fedoraproject.org/wiki/EPEL#How_can_I_use_these_extra_packages.3F

Comment 6 Marcin Trendota 2020-01-09 10:03:57 UTC
Now it indeed works. Thank you!

Comment 7 Richard Shaw 2020-01-09 13:56:56 UTC
Can you let me know when you've successfully setup the server and completed some backups? I don't want to close the bug until we've verified basic functionality.

Comment 8 Richard Shaw 2020-01-19 16:49:59 UTC
Assuming no news is good news. Closing.

Comment 9 Marcin Trendota 2020-02-18 10:22:45 UTC
Yes. Sorry for such long delay. For last week or so everything was working just fine, so i think it's all good. Thank you.

Comment 10 Richard Shaw 2020-02-18 13:40:20 UTC
Thanks for the report! I hope it's working well. Since EL doesn't support upgrading I've been hesitant to reinstall my CentOS 7 server with 8 but I will soon purchase a new server (well new to me off Ebay) to do a fresh install so I can make sure all the services I care about work before decommissioning the EL 7 server.


Note You need to log in before you can comment on or make changes to this bug.