Bug 177546 - file -> print causes evo to quit unexpectantly
file -> print causes evo to quit unexpectantly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgnomecups (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
: Desktop
: 179817 (view as bug list)
Depends On:
Blocks: FC5Blocker 179817
  Show dependency treegraph
 
Reported: 2006-01-11 13:23 EST by Jesse Keating
Modified: 2013-03-13 00:49 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 13:29:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2006-01-11 13:23:12 EST
Shell shows this: 

** ERROR **: file dbus-gmain.c: line 265 (connection_setup_add_watch): assertion
failed: (dbus_watch_get_data (watch) == NULL)
aborting...

Reproducable on mine and jeremy katz's systems.
Comment 1 Dave Malcolm 2006-01-11 19:47:47 EST
Looks like a gnome-cups issue:
libgnomecups-0.2.2-3
evolution-2.5.4-4
dbus-glib-0.60-3
libgnomeprint22-2.12.1-3


Backtrace was generated from '/usr/bin/evolution'

Using host libthread_db library "/lib/libthread_db.so.1".
`shared object read from target memory' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1208174928 (LWP 6137)]
[New Thread -1324352592 (LWP 6573)]
[New Thread -1276159056 (LWP 6220)]
[New Thread -1309684816 (LWP 6219)]
[New Thread -1299194960 (LWP 6218)]
[New Thread -1288705104 (LWP 6161)]
[New Thread -1278215248 (LWP 6160)]
[New Thread -1253672016 (LWP 6159)]
[New Thread -1243182160 (LWP 6157)]
[New Thread -1232692304 (LWP 6156)]
[New Thread -1221764176 (LWP 6155)]
0x00c4e402 in __kernel_vsyscall ()
#0  0x00c4e402 in __kernel_vsyscall ()
#1  0x0018706b in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x06dec38d in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  IA__g_logv (log_domain=) at gmessages.c:503
#5  0x008b053e in IA__g_log (log_domain=0x0, log_level=G_LOG_LEVEL_ERROR, 
    format=0x8d59c0 "file %s: line %d (%s): assertion failed: (%s)") at
gmessages.c:517
#6  0x008b05aa in IA__g_assert_warning (log_domain=0x0, file=0xd4b175
"dbus-gmain.c", line=265, 
    pretty_function=0xd4b3ba "connection_setup_add_watch", expression=0xd4b294
"dbus_watch_get_data (watch) == NULL")
    at gmessages.c:552
#7  0x00d3b1ce in dbus_g_connection_flush () from /usr/lib/libdbus-glib-1.so.2
#8  0x00d3b6e0 in dbus_g_connection_flush () from /usr/lib/libdbus-glib-1.so.2
#9  0x00d3ba07 in dbus_connection_setup_with_g_main () from
/usr/lib/libdbus-glib-1.so.2
#10 0x00105672 in gnome_cups_printer_free_reasons () from
/usr/lib/libgnomecups-1.0.so.1
#11 0x001057c3 in gnome_cups_printer_new_printer_notify_add () from
/usr/lib/libgnomecups-1.0.so.1
#12 0x04ba9ed1 in ?? () from
/usr/lib/libgnomeprint/2.12.1/modules/libgnomeprintcups.so
#13 0x05a99afd in gpa_printer_list_load () from /usr/lib/libgnomeprint-2-2.so.0
#14 0x05a9a202 in gpa_init () from /usr/lib/libgnomeprint-2-2.so.0
#15 0x05a9ade0 in gpa_config_from_string () from /usr/lib/libgnomeprint-2-2.so.0
#16 0x05a6a1bb in gnome_print_config_from_string () from
/usr/lib/libgnomeprint-2-2.so.0
#17 0x00c055d0 in e_print_load_config () at e-print.c:43
#18 0x046d24bf in em_folder_view_print (emfv=0x9bb9690, preview=1) at
em-folder-view.c:2107
#19 0x046d25ea in emfv_print_preview_message (uic=0x98ab398, data=0x9bb9690,
path=0xaf88048 "PrintPreviewMessage")
    at em-folder-view.c:1482
#20 0x06e5b1e5 in marshal_VOID__USER_DATA_STRING (closure=0x9d04800,
return_value=0xbfff7f64, n_param_values=2, 
    param_values=0xacc75e0, invocation_hint=0x0, marshal_data=0x46d25c5) at
bonobo-ui-component.c:221
#21 0x005a5c38 in IA__g_closure_invoke (closure=0x9d04800,
return_value=0xbfff7f64, n_param_values=2, 
    param_values=0xacc75e0, invocation_hint=0x0) at gclosure.c:490
#22 0x059bc56a in bonobo_closure_invoke_va_list () from /usr/lib/libbonobo-2.so.0
#23 0x059bc858 in bonobo_closure_invoke () from /usr/lib/libbonobo-2.so.0
#24 0x06e5d6a5 in impl_Bonobo_UIComponent_execVerb (servant=0x98ab3ac,
cname=0xacc7508 "PrintPreviewMessage", 
    ev=0xbfff80c8) at bonobo-ui-component.c:158
#25 0x059bd58b in _ORBIT_skel_small_Bonobo_UIComponent_execVerb () from
/usr/lib/libbonobo-2.so.0
#26 0x058fcb25 in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
#27 0x059c11ea in Bonobo_UIComponent_execVerb () from /usr/lib/libbonobo-2.so.0
#28 0x06e61ae8 in impl_emit_verb_on (engine=0x9b35328, node=0x9ceb6e8) at
bonobo-ui-engine.c:1533
#29 0x005b300c in IA__g_cclosure_marshal_VOID__POINTER (closure=0x9b35108,
return_value=0x0, n_param_values=2, 
    param_values=0xbfff838c, invocation_hint=0xbfff828c, marshal_data=0x6e61933)
at gmarshal.c:601
#30 0x005a5605 in g_type_class_meta_marshal (closure=0x9b35108,
return_value=0x0, n_param_values=2, 
    param_values=0xbfff838c, invocation_hint=0xbfff828c, marshal_data=0x4c) at
gclosure.c:567
#31 0x005a5c38 in IA__g_closure_invoke (closure=0x9b35108, return_value=0x0,
n_param_values=2, 
    param_values=0xbfff838c, invocation_hint=0xbfff828c) at gclosure.c:490
#32 0x005b5cee in signal_emit_unlocked_R (node=0x9b35158, detail=0,
instance=0x9b35328, emission_return=0x0, 
    instance_and_params=0xbfff838c) at gsignal.c:2487
#33 0x005b70b8 in IA__g_signal_emit_valist (instance=0x9b35328, signal_id=186,
detail=0, 
    var_args=0xbfff8590 "
c´\tX¢Î\tÈ\205ÿ\001pûè\006\221wæ\006È5Ì\tÈ\205ÿ¿Æwæ\006(S³\tÈ5Ì\tè\205ÿ¿H\006\221")
    at gsignal.c:2208
#34 0x005b7409 in IA__g_signal_emit (instance=0x9b35328, signal_id=186,
detail=0) at gsignal.c:2252
#35 0x06e6130e in bonobo_ui_engine_emit_verb_on_w (engine=0x9b35328,
widget=0x9cc35c8) at bonobo-ui-engine.c:3040
#36 0x06e677c6 in exec_verb_cb (item=0x9cc35c8, engine=0x9b35328) at
bonobo-ui-sync-menu.c:445
#37 0x005b2623 in IA__g_cclosure_marshal_VOID__VOID (closure=0x9cea258,
return_value=0x0, n_param_values=1, 
    param_values=0xbfff882c, invocation_hint=0xbfff872c, marshal_data=0x6e67791)
at gmarshal.c:77
#38 0x005a5c38 in IA__g_closure_invoke (closure=0x9cea258, return_value=0x0,
n_param_values=1, 
    param_values=0xbfff882c, invocation_hint=0xbfff872c) at gclosure.c:490
#39 0x005b5595 in signal_emit_unlocked_R (node=0x9b47808, detail=0,
instance=0x9cc35c8, emission_return=0x0, 
    instance_and_params=0xbfff882c) at gsignal.c:2449
#40 0x005b70b8 in IA__g_signal_emit_valist (instance=0x9cc35c8, signal_id=205,
detail=0, 
    var_args=0xbfff8a2c "hÑ\213") at gsignal.c:2208
#41 0x005b7409 in IA__g_signal_emit (instance=0x9cc35c8, signal_id=205,
detail=0) at gsignal.c:2252
#42 0x057b2eed in IA__gtk_widget_activate (widget=0x9cc35c8) at gtkwidget.c:3766
#43 0x056dfdef in IA__gtk_menu_shell_activate_item (menu_shell=0x9b428e8,
menu_item=0x9cc35c8, force_deactivate=1)
    at gtkmenushell.c:1057
#44 0x056e00c1 in gtk_menu_shell_button_release (widget=0x9b428e8,
event=0xaec0ee0) at gtkmenushell.c:663
#45 0x056d6864 in gtk_menu_button_release (widget=0x9b428e8, event=0xaec0ee0) at
gtkmenu.c:2571
#46 0x056d1170 in _gtk_marshal_BOOLEAN__BOXED (closure=0x98a4910,
return_value=0xbfff8c40, n_param_values=2, 
    param_values=0xbfff8d2c, invocation_hint=0xbfff8c2c, marshal_data=0x56d6815)
at gtkmarshalers.c:83
#47 0x005a5605 in g_type_class_meta_marshal (closure=0x98a4910,
return_value=0xbfff8c40, n_param_values=2, 
    param_values=0xbfff8d2c, invocation_hint=0xbfff8c2c, marshal_data=0xb4) at
gclosure.c:567
#48 0x005a5c38 in IA__g_closure_invoke (closure=0x98a4910,
return_value=0xbfff8c40, n_param_values=2, 
    param_values=0xbfff8d2c, invocation_hint=0xbfff8c2c) at gclosure.c:490
#49 0x005b5cee in signal_emit_unlocked_R (node=0x98a4c70, detail=0,
instance=0x9b428e8, emission_return=0xbfff8eac, 
    instance_and_params=0xbfff8d2c) at gsignal.c:2487
#50 0x005b6e16 in IA__g_signal_emit_valist (instance=0x9b428e8, signal_id=49,
detail=0, 
    var_args=0xbfff8f30 "H\217ÿ¿à\016ì\nè(´\t¡2{\005è(´\t0{\211\t") at
gsignal.c:2218
#51 0x005b7409 in IA__g_signal_emit (instance=0x9b428e8, signal_id=49, detail=0)
at gsignal.c:2252
#52 0x057b30cf in gtk_widget_event_internal (widget=0x9b428e8, event=0xaec0ee0)
at gtkwidget.c:3735
#53 0x056cf8ed in IA__gtk_propagate_event (widget=0x9b428e8, event=0xaec0ee0) at
gtkmain.c:2169
#54 0x056cfcfc in IA__gtk_main_do_event (event=0xaec0ee0) at gtkmain.c:1406
#55 0x0033377f in gdk_event_dispatch (source=0x9889c48, callback=0,
user_data=0x0) at gdkevents-x11.c:2291
#56 0x008a7137 in IA__g_main_context_dispatch (context=0x9889ca0) at gmain.c:1913
#57 0x008aa12c in g_main_context_iterate (context=0x9889ca0, block=1,
dispatch=1, self=0x98733f8) at gmain.c:2544
#58 0x008aa458 in IA__g_main_loop_run (loop=0x9a73768) at gmain.c:2748
#59 0x059aa5a0 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#60 0x0805d52a in main (argc=1, argv=0xbfff9464) at main.c:606
#61 0x00df062f in __libc_start_main () from /lib/libc.so.6
#62 0x0804fe31 in _start ()

Thread 11 (Thread -1221764176 (LWP 6155)):
#0  0x00c4e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00183856 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x003c4139 in e_msgport_wait (mp=0x9a902c0) at e-msgport.c:660
No locals.
#3  0x003c4259 in thread_dispatch (din=0x9a3eb88) at e-msgport.c:1022
	e = 
Thread 10 (Thread -1232692304 (LWP 6156)):
#0  0x00c4e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00e9cd50 in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x008a9f82 in g_main_context_iterate (context=0x9b907a0, block=1,
dispatch=1, self=0x9b8cf00) at gmain.c:2846
	max_priority = 2147483647
	timeout = -1
	some_ready = 
Thread 9 (Thread -1243182160 (LWP 6157)):
#0  0x00c4e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00183856 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x003c4139 in e_msgport_wait (mp=0x9bac088) at e-msgport.c:660
No locals.
#3  0x003c4259 in thread_dispatch (din=0x9bac358) at e-msgport.c:1022
	e = 
Thread 8 (Thread -1253672016 (LWP 6159)):
#0  0x00c4e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00183856 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x003c4139 in e_msgport_wait (mp=0x9a3ea88) at e-msgport.c:660
No locals.
#3  0x003c4259 in thread_dispatch (din=0x9a3ea28) at e-msgport.c:1022
	e = 
Thread 7 (Thread -1278215248 (LWP 6160)):
#0  0x00c4e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00183856 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x003c4139 in e_msgport_wait (mp=0x9a3eb38) at e-msgport.c:660
No locals.
#3  0x003c4259 in thread_dispatch (din=0x9a3ead8) at e-msgport.c:1022
	e = 
Thread 6 (Thread -1288705104 (LWP 6161)):
#0  0x00c4e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00183856 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x003c4139 in e_msgport_wait (mp=0x9a902c0) at e-msgport.c:660
No locals.
#3  0x003c4259 in thread_dispatch (din=0x9a3eb88) at e-msgport.c:1022
	e = 
Thread 5 (Thread -1299194960 (LWP 6218)):
#0  0x00c4e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00183856 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x003c4139 in e_msgport_wait (mp=0x9a902c0) at e-msgport.c:660
No locals.
#3  0x003c4259 in thread_dispatch (din=0x9a3eb88) at e-msgport.c:1022
	e = 
Thread 4 (Thread -1309684816 (LWP 6219)):
#0  0x00c4e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00183856 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x003c4139 in e_msgport_wait (mp=0x9a902c0) at e-msgport.c:660
No locals.
#3  0x003c4259 in thread_dispatch (din=0x9a3eb88) at e-msgport.c:1022
	e = 
Thread 3 (Thread -1276159056 (LWP 6220)):
#0  0x00c4e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00e9cd50 in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x008a9f82 in g_main_context_iterate (context=0x9fdb518, block=1,
dispatch=1, self=0x9c3c470) at gmain.c:2846
	max_priority = 2147483647
	timeout = -1
	some_ready = 
Thread 2 (Thread -1324352592 (LWP 6573)):
#0  0x00c4e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00e9cd50 in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x008a9f82 in g_main_context_iterate (context=0xad1eab0, block=1,
dispatch=1, self=0xac7e360) at gmain.c:2846
	max_priority = 2147483647
	timeout = -1
	some_ready = 
Thread 1 (Thread -1208174928 (LWP 6137)):
#0  0x00c4e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x0018706b in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x06dec38d in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  IA__g_logv (log_domain=) at gmessages.c:503
	depth = 1
	domain = (GLogDomain *) 0x0
	data = 0x0
	log_func = 0x8b0b43 <IA__g_log_default_handler>
	domain_fatal_mask = 5
	test_level = 
Comment 2 Dave Malcolm 2006-01-13 14:11:54 EST
Looks very similar to:
http://bugzilla.gnome.org/show_bug.cgi?id=326785

It looks like a single process can only call dbus_connection_setup_with_g_main once.

Evolution already calls this for its NetworkManager integration; when you print,
the libgnomecups code also calls it internally.
Comment 3 Dave Malcolm 2006-01-13 19:10:40 EST
Does this fail for any other applications that use gnome-pring and that use DBus
in some other way?
Comment 4 Matthias Clasen 2006-02-13 23:57:00 EST
Upstream bug on this issue: http://bugzilla.gnome.org/show_bug.cgi?id=326572
Comment 5 Jeremy Katz 2006-02-14 16:17:23 EST
*** Bug 179817 has been marked as a duplicate of this bug. ***
Comment 6 Matthias Clasen 2006-02-17 14:34:31 EST
The library to blame here is most likely libnm. 

It creates its own main context, main loop and uses that to busy-wait in
a separate thread for dbus to appear. Why the hell is it doing that, and
why does it need a mainloop to do that busy-wait thing ? The right thing
to do should be to just require dbus to be initialized before libnm, and
get rid of all that complication. Calling dbus_connection_setup_with_g_main()
with a non-NULL context from a library must be an error.
Comment 7 Matthias Clasen 2006-02-17 14:45:21 EST
If we can't get this fixed for fc5, we should rebuild evo without NetworkManager
integration, imo. And probably epiphany as well.
Comment 8 Dan Williams 2006-02-20 13:52:27 EST
libnm_glib needs to use dbus_bus_get_private() rather than dbus_bus_get().
Comment 9 Dan Williams 2006-02-21 00:51:00 EST
Note that it appears that libgnomecups does the same thing as libnm_glib does
here, it sets up it's own dbus connection and calls it's own
dbus_connection_setup_with_g_main().  It should probably call
dbus_bus_get_private() as well.
Comment 10 Dan Williams 2006-02-21 01:23:45 EST
Fixed in NM cvs, pushing to Rawhide as:

NetworkManager-0.5.1-13.cvs20060221

Tossing bug over to libgnomecups so issue can be fixed there as well.
Comment 11 Dave Malcolm 2006-02-22 12:19:16 EST
Tested with NetworkManager-0.5.1-13.cvs20060221, evolution printing seems to be
working again.

Sounds like libgnomecups still needs fixing though
Comment 12 John (J5) Palmieri 2006-02-22 12:22:32 EST
Nooooooo.  Pretty soon every application will have 20 sockets open.  We really
need to find a better solution.
Comment 13 Need Real Name 2006-03-01 02:41:25 EST
Why is this no longer a blocker?
Comment 14 John (J5) Palmieri 2006-03-01 09:37:41 EST
This should be fixed with the latest update to NetworkManager and evo.
Comment 15 Need Real Name 2006-03-01 10:08:02 EST
Okay, great - thanks.

Shouldn't this be re-marked as an FC5Blocker, then marked as RESOLVED RAWHIDE?

Note You need to log in before you can comment on or make changes to this bug.