Bug 179817 - printing cause evolution to crash
printing cause evolution to crash
Status: CLOSED DUPLICATE of bug 177546
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
: 180330 (view as bug list)
Depends On: 177546
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-03 00:44 EST by Lawrence Lim
Modified: 2014-03-25 20:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-14 16:17:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
email with CJKI contents (24.89 KB, text/plain)
2006-02-03 00:44 EST, Lawrence Lim
no flags Details
email with english contents (4.73 KB, text/plain)
2006-02-03 00:46 EST, Lawrence Lim
no flags Details
backtrace obtained from bug buddy (10.38 KB, text/plain)
2006-02-03 00:49 EST, Lawrence Lim
no flags Details

  None (edit)
Description Lawrence Lim 2006-02-03 00:44:46 EST
Description of problem:
Tried an print an email in both zh_CN and en_US locale with en_US contents and
CJK contents. After the print option has been selected, evolution will crash.
Both rawhide and FC5 Test 2 have been tried.

Version-Release number of selected component (if applicable):
evolution-2.5.4-2

How reproducible:
Always

Steps to Reproduce:
1.start evolution in en_US or zn_CN locale
2.import both email attached
3.try to print them
  
Actual results:
evolution crash

Expected results:
evolution should print out the email

Additional info:
not i18n specific
Comment 1 Lawrence Lim 2006-02-03 00:44:46 EST
Created attachment 124089 [details]
email with CJKI contents
Comment 2 Lawrence Lim 2006-02-03 00:46:10 EST
Created attachment 124090 [details]
email with english contents
Comment 3 Lawrence Lim 2006-02-03 00:49:24 EST
Created attachment 124093 [details]
backtrace obtained from bug buddy
Comment 4 Lawrence Lim 2006-02-03 01:21:03 EST
Same issue in calendar as well.
Comment 5 Dave Malcolm 2006-02-06 20:03:16 EST
General problem with evolution printing, see release notes; it's a low-level
DBus issue.
Comment 6 Lawrence Lim 2006-02-06 20:33:03 EST
Thanks for the update Dave. I will make a note on that and submit bug upstream
at the end of the cycle if its not reported.
Comment 7 Dave Malcolm 2006-02-06 20:43:00 EST
Unfortunately it's a downstream bug i.e. it's fedora-specific; specifically,
AIUI we patch libgnomecups to have dbus support, and the combination of the dbus
code from libgnomecups via libgnomeprintui and the dbus code via evolution's
NetworkManager support makes evolution crash on printing, deep inside the dbus
code.  There's a bug about this, but I don't have the ID to hand
Comment 8 Lawrence Lim 2006-02-07 02:08:45 EST
Yes. Bug 177546 looks like the problem.
Comment 9 Kris Buytaert 2006-02-08 07:22:12 EST
Still there in 2.5.5.1 
Comment 10 Jeremy Katz 2006-02-14 16:17:06 EST

*** This bug has been marked as a duplicate of 177546 ***
Comment 11 Matthias Clasen 2006-03-06 20:39:44 EST
*** Bug 180330 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.