Bug 1775623 - GCE CR info shows zone field as url field.
Summary: GCE CR info shows zone field as url field.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: 6.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: 6.7.0
Assignee: Oleh Fedorenko
QA Contact: Jitendra Yejare
URL:
Whiteboard:
: 1775617 1775618 1775621 1775622 (view as bug list)
Depends On:
Blocks: 1721890
TreeView+ depends on / blocked
 
Reported: 2019-11-22 12:44 UTC by Kavita
Modified: 2020-04-14 15:54 UTC (History)
8 users (show)

Fixed In Version: tfm-rubygem-hammer_cli_foreman-0.19.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-14 15:54:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 28135 Low Closed GCE CR info shows zone field as url field. 2020-02-27 08:13:23 UTC
Red Hat Product Errata RHBA-2020:1455 None None None 2020-04-14 15:54:21 UTC

Description Kavita 2019-11-22 12:44:08 UTC
Description of problem:
GCE hammer Compute Resource info shows zone field as url field.

Version-Release number of selected component (if applicable):


How reproducible:
------------------
Always



Steps to Reproduce:
1. Create a GCE Compute resource with zone.
2. hammer info the GCE CR.
    1. hammer compute-resource info --id 1

Actual results:
1. The GCE info shows zone field as an url field.

Id: 1
Name: gceCR
Provider: Google
Url: us-central1-a

Expected results:
1. Hammer CR info should show zone field as zone field and not the url field.

Additional info:

Comment 3 Bryan Kearney 2019-11-22 13:04:36 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/28135 has been resolved.

Comment 5 Brad Buckingham 2019-11-22 14:20:04 UTC
*** Bug 1775622 has been marked as a duplicate of this bug. ***

Comment 6 Brad Buckingham 2019-11-22 14:20:06 UTC
*** Bug 1775621 has been marked as a duplicate of this bug. ***

Comment 7 Brad Buckingham 2019-11-22 14:20:08 UTC
*** Bug 1775618 has been marked as a duplicate of this bug. ***

Comment 8 Brad Buckingham 2019-11-22 14:20:12 UTC
*** Bug 1775617 has been marked as a duplicate of this bug. ***

Comment 10 Jitendra Yejare 2019-12-10 08:35:58 UTC
Tested !

Versions:
-------------
Satellite 6.7 snap 5.
tfm-rubygem-hammer_cli_foreman-0.19.3-1.el7sat.noarch
foreman-gce-1.24.0-0.14.RC3.el7sat.noarch

Observation:
-------------
1. I could see that the new 'Zone' field has been added to the GCE CR info.
2. But the existing Url field is still exists which looks like a common field for all the CRs.


Expecting:
--------------
1. Either to remove the Url field for GCE CR.
2. If it's common for all CRs and if we cant remove the entire field, just keep the Url field value blank for GCE CR.


NeedInfoing Assignee !!

Comment 11 Oleh Fedorenko 2019-12-12 16:45:29 UTC
Hi Jitendra,

I've created PR[1] which removes the Url field from GCE info. I assume the fix will be available in hammer-cli-foreman-0.19.5

[1] - https://github.com/theforeman/hammer-cli-foreman/pull/466

Comment 14 Jitendra Yejare 2020-02-27 08:18:28 UTC
Verified!


Observations:
--------------------
1. The zone field is showing correctly with zone name.
2. The url field is now removed from GCE CR info.


Logs:
-------------------
[root@qeblade36 ~]# hammer compute-resource info --id 1

Id:            1
Name:          gceCR
Provider:      Google
Description:   
Locations:     
    Default Location
Organizations: 
    Default Organization
Created at:    2019/12/18 06:53:00
Updated at:    2020/01/09 10:41:18
Project:       sat6qe
Email:         <someemail>
Key Path:      <somekey.json>
Zone:          us-east1-c

Comment 17 errata-xmlrpc 2020-04-14 15:54:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1455


Note You need to log in before you can comment on or make changes to this bug.