Bug 177597 - text mode install is all garbled
text mode install is all garbled
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-01-11 21:00 EST by Peter Quiring
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-25 10:40:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Sample pics of what it looks like. (186.18 KB, application/octet-stream)
2006-01-12 13:18 EST, Peter Quiring
no flags Details

  None (edit)
Description Peter Quiring 2006-01-11 21:00:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
When installing in text mode all of the text seems to be slightly shifted from when it redraws boxes/windows/text etc.

Seems as though a screen will get drawn once correctly, but then is redrawn "shifted".

Also seeing some ascii chars > 128 where there shouldn't be.

This is only seen when using "linux text".
There is no problem with using "linux rescue" mode.

It's still possible to move around and attempt an install (although VERY confusing), except I'm still getting exceptions even if I don't deselect packages.


Version-Release number of selected component (if applicable):
anaconda-10.91.2-1.x86_64.rpm

How reproducible:
Always

Steps to Reproduce:
1.Boot from DVD
2.linux text
3.
  

Actual Results:  garbled text

Expected Results:  ungarbled text.

Additional info:

I've seen this since FC5t1, just finally get around to reporting it now.
Comment 1 Peter Quiring 2006-01-11 21:05:39 EST
FYI - I can't install in graphics mode due to bug#175020 which is an X11 bug.
Comment 2 Chris Lumens 2006-01-12 10:05:09 EST
What language are you using for installation?
Comment 3 Peter Quiring 2006-01-12 12:55:21 EST
English (default)
Comment 4 Peter Quiring 2006-01-12 13:18:48 EST
Created attachment 123129 [details]
Sample pics of what it looks like.

3 pics.
Comment 5 Ricky Ng-Adam 2006-01-16 23:00:39 EST
I have the same problem with FC5t2. I think it reverts back to text install
because I don't have sufficient memory? (192M).
Comment 6 Jeremy Katz 2006-01-18 11:20:38 EST
We probably need to do the nl_langinfo stubbing in stubs/unicode-lite.c that I
had to add to loader2/wcstubs.c
Comment 7 Andy Burns 2006-01-22 07:48:30 EST
Just to mention I don't get this screen garbling on a serial console, but do get
it on a vgaconsole ...
Comment 8 David Cantrell 2006-01-25 10:40:51 EST
We've fixed this in rawhide.

Note You need to log in before you can comment on or make changes to this bug.