Bug 177600 - up2date fails to update hpijs-1.7.1-3.i386.rpm due to outdated dependency in foomatic-3.0.2-19.i386.rpm
up2date fails to update hpijs-1.7.1-3.i386.rpm due to outdated dependency in ...
Status: CLOSED DUPLICATE of bug 177230
Product: Fedora
Classification: Fedora
Component: hpijs (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-11 22:24 EST by Fred Bourgeois
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-12 06:36:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred Bourgeois 2006-01-11 22:24:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
When running up2date or yum against a freshly installed FC4 distro, rpm fails to install hpijs-0.9.7-4.2.i386.rpm due to requirement in foomatic-3.0.2-19.i386.rpm for "hpijs version > 1.5".

The distr includes hpijs-1.7.1-3.i386.rpm but apparently the version number of the hpijs-0.9.7 package is for a newer release.

Perhaps this should be reported as a bug in the foomatic RPM instead of hpijs?

Version-Release number of selected component (if applicable):
hpijs-1.7.1-3.i386.rpm, hpijs-0.9.7-4.2.i386.rpm, foomatic-3.0.2-19.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1.  Install FC4
2.  Run up2date
3.  Select "hpijs" as the package to upgrade (note that several other packages also have problems updating due to dependencies on older kernels)
  

Actual Results:  Unresolvable package dependencies message from up2date, apparently due to backward change in hpijs version numbers and old dependencies in the distributed foomatic package.

Expected Results:  There should be a new foomatic RPM that incorporates the changes in hpijs versioning.

Additional info:
Comment 1 Tim Waugh 2006-01-12 06:36:58 EST
I need to get feedback about the updates-testing foomatic package, so that I can
release it as a proper update.

*** This bug has been marked as a duplicate of 177230 ***

Note You need to log in before you can comment on or make changes to this bug.