Bug 1776190 - Selecting VM template in VM creation wizard closes the wizard window
Summary: Selecting VM template in VM creation wizard closes the wizard window
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Filip Krepinsky
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On:
Blocks: 1776812
TreeView+ depends on / blocked
 
Reported: 2019-11-25 09:40 UTC by vsibirsk
Modified: 2020-05-04 11:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Selecting a template without annotations was crashing the VM wizard Fix: NPE fixed, wizard no longer crashes
Clone Of:
: 1776812 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:16:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
windowstemplate (2.95 KB, text/plain)
2019-11-26 09:45 UTC, Tomas Jelinek
no flags Details
example-template (2.12 KB, text/plain)
2019-11-26 11:29 UTC, vsibirsk
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3578 0 'None' closed Bug 1776190: fix selecting a template without annotations in VM wizard 2020-05-04 11:49:00 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:17:24 UTC

Description vsibirsk 2019-11-25 09:40:43 UTC
Description of problem:
Selecting default VM template with modified yaml (added network adapter) instantly closes the wizard window.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Create default VM template
2.Edit template yaml to add network adapter & save:
  interfaces:
    - masquerade: {}
      name: default
3.Create VM via wizard and select template from step 1.

Actual results:
Wizard windows instantly closed without any message/error.

Expected results:

Additional info:

Comment 1 Tomas Jelinek 2019-11-26 09:45:33 UTC
Created attachment 1639747 [details]
windowstemplate

Comment 2 Tomas Jelinek 2019-11-26 09:46:43 UTC
I've managed to reproduce it with the attached template. But did not manage to reproduce it by manipulating the interfaces. Can you please attach your full template yaml to make sure it is the same issue?

Comment 3 vsibirsk 2019-11-26 11:29:49 UTC
Created attachment 1639772 [details]
example-template

Comment 4 vsibirsk 2019-11-26 11:35:44 UTC
Attached.

Modified part (lines 48-50):
              interfaces:
                - masquerade: {}
                  name: default

Comment 6 Radim Hrazdil 2019-11-29 09:45:23 UTC
Unable to verify using the reprofuction steps given in the description.

I created VM Template using the default YAML and added
```
interfaces:
  - masquerade: {}
    name: default

```
Then, when I select this template in VM Wizard, the wizard doesn't close, however, Source, OS and Workload Profile are not selected so it's not possible to proceed.
Filip, could you take a look?

Comment 7 Radim Hrazdil 2019-11-29 13:21:12 UTC
Moving to Verified after discussing issue described in the previous comment over private channel.

Comment 9 errata-xmlrpc 2020-05-04 11:16:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.