Bug 1776812 - Selecting VM template in VM creation wizard closes the wizard window
Summary: Selecting VM template in VM creation wizard closes the wizard window
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.3.0
Assignee: Filip Krepinsky
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On: 1776190
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-26 12:32 UTC by Filip Krepinsky
Modified: 2020-01-23 11:14 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1776190
Environment:
Last Closed: 2020-01-23 11:14:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3589 'None' 'closed' '[release-4.3] Bug 1776812: fix selecting a template without annotations in VM wizard' 2019-12-04 07:57:42 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:14:48 UTC

Description Filip Krepinsky 2019-11-26 12:32:55 UTC
+++ This bug was initially created as a clone of Bug #1776190 +++

Description of problem:
Selecting default VM template with modified yaml (added network adapter) instantly closes the wizard window.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Create default VM template
2.Edit template yaml to add network adapter & save:
  interfaces:
    - masquerade: {}
      name: default
3.Create VM via wizard and select template from step 1.

Actual results:
Wizard windows instantly closed without any message/error.

Expected results:

Additional info:

--- Additional comment from Tomas Jelinek on 2019-11-26 09:45:33 UTC ---



--- Additional comment from Tomas Jelinek on 2019-11-26 09:46:43 UTC ---

I've managed to reproduce it with the attached template. But did not manage to reproduce it by manipulating the interfaces. Can you please attach your full template yaml to make sure it is the same issue?

--- Additional comment from  on 2019-11-26 11:29:49 UTC ---



--- Additional comment from  on 2019-11-26 11:35:44 UTC ---

Attached.

Modified part (lines 48-50):
              interfaces:
                - masquerade: {}
                  name: default

Comment 2 Guohua Ouyang 2019-12-10 03:52:26 UTC
Verified on 4.3.0-0.nightly-2019-12-04-054458, the VM wizard is not closed by using a edited default template.

Comment 4 errata-xmlrpc 2020-01-23 11:14:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.