Bug 1776379 - ocp 4.2 failures because: "aws: command not found"
Summary: ocp 4.2 failures because: "aws: command not found"
Keywords:
Status: CLOSED DUPLICATE of bug 1775531
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Eric Duen
QA Contact: David Sanz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-25 14:48 UTC by Lokesh Mandvekar
Modified: 2019-11-25 15:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-25 15:50:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 2663 0 'None' closed OpenStack CI: add awscli to the CI image 2020-04-28 21:36:45 UTC

Internal Links: 1775531

Description Lokesh Mandvekar 2019-11-25 14:48:33 UTC
Description of problem:

Please re-assign if "openshift on openstack" isn't the right place to report this..

many openstack related test failures occurring since yesterday for 4.2 at
https://prow.svc.ci.openshift.org/?job=release-*-openstack*-4.2&state=failure

https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-openstack-4.2/251
https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-openstack-serial-4.2/251
https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-origin-installer-e2e-openstack-serial-4.2/202




Run template e2e-openstack - e2e-openstack container setup expand_less 	6s
Lease acquired, installing...
Installing from release registry.svc.ci.openshift.org/ocp/release:4.2-ci
Creating DNS record for api.j7g1psm7-0d645.shiftstack.devcluster.openshift.com. -> 128.31.24.201
/bin/sh: line 61: aws: command not found
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib64/python2.7/json/__init__.py", line 290, in load
    **kw)
  File "/usr/lib64/python2.7/json/__init__.py", line 338, in loads
    return _default_decoder.decode(s)
  File "/usr/lib64/python2.7/json/decoder.py", line 366, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib64/python2.7/json/decoder.py", line 384, in raw_decode
    raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded
/bin/sh: line 62: aws: command not found

Comment 1 Tomas Sedovic 2019-11-25 15:50:29 UTC

*** This bug has been marked as a duplicate of bug 1775531 ***


Note You need to log in before you can comment on or make changes to this bug.