Bug 1776637 - Region for AWS not being passed to the operator while creating a backingstore.
Summary: Region for AWS not being passed to the operator while creating a backingstore.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Ankush Behl
QA Contact: Anna Sandler
URL:
Whiteboard:
Depends On:
Blocks: 1776660
TreeView+ depends on / blocked
 
Reported: 2019-11-26 05:32 UTC by Bipul Adhikari
Modified: 2020-05-04 11:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1776660 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:17:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:17:36 UTC

Description Bipul Adhikari 2019-11-26 05:32:33 UTC
Description of problem:
Region value is not passed to operator while creating backingstore.


Version-Release number of selected component (if applicable):
4.3.0

How reproducible:
Easily


Steps to Reproduce:
1. Create an AWS backingsore with region value selected.


Actual results:
YAML doesn't have region value.

Expected results:
YAML should have region value.

Comment 2 Anna Sandler 2019-12-12 13:28:59 UTC
fixed. Created a AWS backing store using the UI: Operators -> Installed Operators -> Backing Store (on the top bar) -> create backing store -> set providers AWS S3 and specified a region -> create. In the yaml of the BS a region was specified successfully
(couldn't do that using CLI duo to some NooBaa CLI Problems) 

*same as bug #1776660

Comment 3 Elad 2019-12-12 13:34:07 UTC
Bipul, I changed the target release here to 4.4.0 as I believe this was the intention.

Comment 4 Bipul Adhikari 2019-12-18 04:16:05 UTC
Yes thanks Elad!

Comment 7 errata-xmlrpc 2020-05-04 11:17:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.