Bug 1776660 - Region for AWS not being passed to the operator while creating a backingstore.
Summary: Region for AWS not being passed to the operator while creating a backingstore.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: Ankush Behl
QA Contact: Anna Sandler
URL:
Whiteboard:
Depends On: 1776637
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-26 06:00 UTC by Bipul Adhikari
Modified: 2020-01-23 11:14 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1776637
Environment:
Last Closed: 2020-01-23 11:14:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3572 0 'None' 'open' 'Bug 1776660: [release-4.3] BS creation payload updated' 2019-11-26 06:16:02 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:14:31 UTC

Description Bipul Adhikari 2019-11-26 06:00:03 UTC
+++ This bug was initially created as a clone of Bug #1776637 +++

Description of problem:
Region value is not passed to operator while creating backingstore.


Version-Release number of selected component (if applicable):
4.3.0

How reproducible:
Easily


Steps to Reproduce:
1. Create an AWS backingsore with region value selected.


Actual results:
YAML doesn't have region value.

Expected results:
YAML should have region value.

Comment 2 Anna Sandler 2019-12-12 13:30:45 UTC
fixed. Created a AWS backing store using the UI: Operators -> Installed Operators -> Backing Store (on the top bar) -> create backing store -> set providers AWS S3 and specified a region -> create. In the yaml of the BS a region was specified successfully
(couldn't do that using CLI duo to some NooBaa CLI Problems) 

*same as bug #1776637

Comment 4 errata-xmlrpc 2020-01-23 11:14:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.