Bug 1776951 - Pod tooltip shouldn't be Scaled to Zero when the build has not yet completed
Summary: Pod tooltip shouldn't be Scaled to Zero when the build has not yet completed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Sahil Budhwar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-26 16:12 UTC by Sahil Budhwar
Modified: 2020-05-13 21:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1779487 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:53:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3563 'None' closed Bug 1776951: fix scaling up phase and add it to getPodData 2020-04-27 08:50:53 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:53:20 UTC

Description Sahil Budhwar 2019-11-26 16:12:22 UTC
As a user, if I add something by import from git, the topology view shows me that the build is running, but when I hover over the pod donut, it says "Scaled to 0". That's incorrect

Comment 1 Sahil Budhwar 2019-11-26 16:31:00 UTC

How reproducible:

Steps to Reproduce:
1. Create a new resource using git import form 
2. while the build is running then hovering over pod donut shows `Scaled To 0` which is incorrect and misleading that the user scaled the pods down


Actual results:


Expected results:
1. It should be showing `Scaling up` while hovering over the Pod Donut until the build is not finished


Additional info:

There is a fake pod created right now which shows up in Pods overview list on the resource tab. There shouldn't be any fake pod on the pod overview list.

Comment 3 Gajanan More 2020-03-03 12:42:32 UTC
I have validated this bug on
Build: 4.4.0-0.ci-2020-03-03-033811
Browser: Google Chrome Version 78.0.3904.108

Marking this as verified.

Comment 5 errata-xmlrpc 2020-05-13 21:53:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.