Bug 1779487 - Pod tooltip shouldn't be Scaled to Zero when the build has not yet completed
Summary: Pod tooltip shouldn't be Scaled to Zero when the build has not yet completed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.3.0
Assignee: cvogt
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-04 04:15 UTC by Sahil Budhwar
Modified: 2020-01-23 11:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1776951
Environment:
Last Closed: 2020-01-23 11:17:46 UTC
Target Upstream Version:


Attachments (Terms of Use)
Pod tooltip shouldn't be Scaled to Zero when the build has not yet completed (55.73 KB, image/png)
2020-01-04 13:56 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3661 'None' 'open' '[release-4.3] Bug 1779487: fix scaling up phase and add it to getPodData' 2019-12-04 04:21:58 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:18:04 UTC

Description Sahil Budhwar 2019-12-04 04:15:59 UTC
+++ This bug was initially created as a clone of Bug #1776951 +++

As a user, if I add something by import from git, the topology view shows me that the build is running, but when I hover over the pod donut, it says "Scaled to 0". That's incorrect

--- Additional comment from Sahil Budhwar on 2019-11-26 16:31:00 UTC ---



How reproducible:

Steps to Reproduce:
1. Create a new resource using git import form 
2. while the build is running then hovering over pod donut shows `Scaled To 0` which is incorrect and misleading that the user scaled the pods down


Actual results:


Expected results:
1. It should be showing `Scaling up` while hovering over the Pod Donut until the build is not finished


Additional info:

There is a fake pod created right now which shows up in Pods overview list on the resource tab. There shouldn't be any fake pod on the pod overview list.

Comment 2 spathak@redhat.com 2020-01-04 13:55:18 UTC
Verified in build version: 4.3.0-0.ci-2020-01-03-062415

Comment 3 spathak@redhat.com 2020-01-04 13:55:25 UTC
Verified in build version: 4.3.0-0.ci-2020-01-03-062415

Comment 4 spathak@redhat.com 2020-01-04 13:56:52 UTC
Created attachment 1649676 [details]
Pod tooltip shouldn't be Scaled to Zero when the build has not yet completed

Comment 6 errata-xmlrpc 2020-01-23 11:17:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.