Bug 177696 - Directory Console doesn't build with Java 1.5
Summary: Directory Console doesn't build with Java 1.5
Status: CLOSED CURRENTRELEASE
Alias: None
Product: 389
Classification: Retired
Component: Directory Console   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nathan Kinder
QA Contact: Viktor Ashirov
URL:
Whiteboard: 1.0.2
Keywords: VerifiedUpstream
: 176058 (view as bug list)
Depends On:
Blocks: 183369
TreeView+ depends on / blocked
 
Reported: 2006-01-12 22:46 UTC by Nathan Kinder
Modified: 2015-12-07 17:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 17:16:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch provided by Graham Leggett (minfrin@sharp.fm) (6.43 KB, patch)
2006-01-12 22:46 UTC, Nathan Kinder
no flags Details | Diff
Revised diff (9.52 KB, patch)
2006-01-13 21:36 UTC, Nathan Kinder
no flags Details | Diff
CVS Commit (1.46 KB, text/plain)
2006-01-13 22:50 UTC, Nathan Kinder
no flags Details

Description Nathan Kinder 2006-01-12 22:46:20 UTC
Java 1.5 added "enum" as a reserved keyword.  Console has some spots with
declarations such as:

    Enumeration enum = ...

We need to change "enum" to a different identifier for the build to work.

Comment 1 Nathan Kinder 2006-01-12 22:46:20 UTC
Created attachment 123142 [details]
Patch provided by Graham Leggett (minfrin@sharp.fm)

Comment 2 Nathan Kinder 2006-01-13 21:36:46 UTC
Created attachment 123179 [details]
Revised diff

I modified the previous patch to have more descriptive variable names than
"enumeration".

Comment 3 Nathan Kinder 2006-01-13 22:50:38 UTC
Created attachment 123183 [details]
CVS Commit

Checked into HEAD.  Reviewed by Noriko.

Comment 4 Nathan Kinder 2006-02-09 16:06:14 UTC
*** Bug 176058 has been marked as a duplicate of this bug. ***

Comment 5 Jenny Galipeau 2011-06-06 18:44:27 UTC
Please add steps to reproduce and verify thanks

Comment 6 Nathan Kinder 2011-06-23 14:41:04 UTC
This is a compilation issue.  We have been building with Java 1.5 and 1.6 for a long time.  Mark as verified upstream.


Note You need to log in before you can comment on or make changes to this bug.