Bug 1777030 - [Multi Arch] oc debug node is unavailable on s390x
Summary: [Multi Arch] oc debug node is unavailable on s390x
Keywords:
Status: CLOSED DUPLICATE of bug 1795277
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Alex Crawford
QA Contact: Jeremy Poulin
URL:
Whiteboard:
Depends On:
Blocks: 1777031
TreeView+ depends on / blocked
 
Reported: 2019-11-26 19:09 UTC by Alex Crawford
Modified: 2020-01-31 00:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1777031 (view as bug list)
Environment:
Last Closed: 2020-01-31 00:02:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 185 'None' closed Bug 1777030: Update support tools container image 2020-04-02 00:46:29 UTC

Description Alex Crawford 2019-11-26 19:09:47 UTC
oc debug node uses registry.redhat.io/rhel7/support-tools, but this container image is only available on AMD64. It should be updated to use registry.redhat.io/rhel8/support-tools, which is a multi-arch container image.

Comment 1 Jeremy Poulin 2019-12-03 16:37:11 UTC
I don't want to move this bug into verified without understanding the reason it has been marked as "Modified"; however, I was able to verify this by building a local oc client off the master branch and using $ oc debug node/*** to connect to a remote node.

Comment 2 Jeremy Poulin 2019-12-03 17:09:36 UTC
Worked for me!

Comment 3 Alex Crawford 2019-12-04 17:39:31 UTC
Apparently we can't support RHEL8 container images on RHEL7 nodes, so the current solution isn't going to work on RHEL7 workers. We are going to try to get the RHEL7 support tools built for s390x instead.

Comment 5 Alex Crawford 2020-01-31 00:02:38 UTC

*** This bug has been marked as a duplicate of bug 1795277 ***


Note You need to log in before you can comment on or make changes to this bug.