Bug 1777031 - oc debug node is unavailable on s390x
Summary: oc debug node is unavailable on s390x
Keywords:
Status: CLOSED DUPLICATE of bug 1795277
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.z
Assignee: Alex Crawford
QA Contact: Jeremy Poulin
URL:
Whiteboard:
Depends On: 1777030 1795277
Blocks: 1778807
TreeView+ depends on / blocked
 
Reported: 2019-11-26 19:11 UTC by Alex Crawford
Modified: 2020-01-31 00:03 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1777030
: 1778807 (view as bug list)
Environment:
Last Closed: 2020-01-31 00:03:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oc pull 196 0 'None' closed Bug 1777031: Update support tools container image 2020-01-31 00:02:52 UTC

Description Alex Crawford 2019-11-26 19:11:03 UTC
+++ This bug was initially created as a clone of Bug #1777030 +++

oc debug node uses registry.redhat.io/rhel7/support-tools, but this container image is only available on AMD64. It should be updated to use registry.redhat.io/rhel8/support-tools, which is a multi-arch container image.

Comment 2 Jeremy Poulin 2019-12-03 16:16:17 UTC
Here's how I tested this:

-- Prebuilt oc 4.1 lient Output --

oc debug node/master-0.ocp-s390x-test-321aff.redhat.com
Starting pod/master-0ocp-s390x-test-321affredhatcom-debug ...
To use host binaries, run `chroot /host`


Removing debug pod ...
error: watch closed before UntilWithoutRetry timeout

-- Locally Built release-4.3 Client Output --
./oc debug node/master-0.ocp-s390x-test-321aff.redhat.com
Starting pod/master-0ocp-s390x-test-321affredhatcom-debug ...
To use host binaries, run `chroot /host`
Pod IP: 10.16.120.67
If you don't see a command prompt, try pressing enter.
sh-4.4# ls  
bin   dev  home  lib	lost+found  mnt  proc  run   srv  tmp  var
boot  etc  host  lib64	media	    opt  root  sbin  sys  usr
sh-4.4#

Looks fixed to me!

Comment 3 Alex Crawford 2019-12-04 17:39:23 UTC
Apparently we can't support RHEL8 container images on RHEL7 nodes, so the current solution isn't going to work on RHEL7 workers. We are going to try to get the RHEL7 support tools built for s390x instead.

Comment 7 Michal Fojtik 2019-12-11 13:02:16 UTC
The PR is merged, why is this in ASSIGNED?

Comment 9 Jeremy Poulin 2019-12-18 03:11:23 UTC
Working on restoring my s390x cluster to verify this, https://bugzilla.redhat.com/show_bug.cgi?id=1777030 and finally https://bugzilla.redhat.com/show_bug.cgi?id=1778807

Comment 12 Alex Crawford 2020-01-31 00:03:55 UTC

*** This bug has been marked as a duplicate of bug 1795277 ***


Note You need to log in before you can comment on or make changes to this bug.