Bug 1777177 - "Insert Example Query" button should also enable the query
Summary: "Insert Example Query" button should also enable the query
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Andrew Pickering
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1777178
TreeView+ depends on / blocked
 
Reported: 2019-11-27 04:12 UTC by Andrew Pickering
Modified: 2020-05-04 11:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1777178 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:17:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3592 'None' closed Bug 1777177: Query Browser: Fix Switch to enable when inserting example query 2020-06-25 21:07:01 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:18:08 UTC

Description Andrew Pickering 2019-11-27 04:12:48 UTC
Description of problem:
Clicking the "Insert Example Query" button should set the query switch to enabled.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Navigate to Monitoring > Metrics
2. Enter a query and run it
3. Disable the query
4. Click the "Insert Example Query" button

Actual results:
Query is run and the results are displayed correctly, but the query switch is still set to disabled.

Expected results:
Query switch should be set to enabled.

Additional info:

Comment 2 shahan 2019-12-16 03:16:32 UTC
1. Navigate to Monitoring > Metrics
2. Enter a query and run it
3. Disable the query
4. Click the "Insert Example Query" button

Then the Query switch is enbaled.
4.4.0-0.nightly-2019-12-15-184910

Comment 4 errata-xmlrpc 2020-05-04 11:17:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.