Bug 1777178 - "Insert Example Query" button should also enable the query
Summary: "Insert Example Query" button should also enable the query
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.0
Assignee: Andrew Pickering
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1777177
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-27 04:14 UTC by Andrew Pickering
Modified: 2020-01-23 11:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1777177
Environment:
Last Closed: 2020-01-23 11:14:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3635 'None' 'open' '[release-4.3] Bug 1777178: Query Browser: Fix Switch to enable when inserting example query' 2019-12-03 04:48:36 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:14:46 UTC

Description Andrew Pickering 2019-11-27 04:14:51 UTC
+++ This bug was initially created as a clone of Bug #1777177 +++

Description of problem:
Clicking the "Insert Example Query" button should set the query switch to enabled.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Navigate to Monitoring > Metrics
2. Enter a query and run it
3. Disable the query
4. Click the "Insert Example Query" button

Actual results:
Query is run and the results are displayed correctly, but the query switch is still set to disabled.

Expected results:
Query switch should be set to enabled.

Additional info:

Comment 2 XiaochuanWang 2019-12-05 07:22:51 UTC
Query set to be enabled as soon as user click "Insert Example Query" button.
Verified on 4.3.0-0.nightly-2019-12-04-214544

Comment 4 errata-xmlrpc 2020-01-23 11:14:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.