Bug 177737 - reproducible exception in package selection
reproducible exception in package selection
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
: 178085 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-13 11:56 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 11:25:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-01-13 11:56:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
If you get to the package selection screen and enable Network Servers, then DNS Server, then disable Network Servers, you get an exception.

Version-Release number of selected component (if applicable):
FC5T2

How reproducible:
Always

Steps to Reproduce:
1.Get to the package selection screen (GUI)
2.Enable Network Servers
3.Enable DNS Server
4.Disable Network Servers

Actual Results:  Exception

Expected Results:  No exception

Additional info:

I suspect it has to do with the fact that there are packages that are in both groups.
Comment 1 Alexandre Oliva 2006-01-13 12:01:18 EST
I was going to attach anacdump.txt, but then I noticed it contains the
(scrambled) password (bad!!) and the exception was pretty simple, so that's all
I'm posting here:

Traceback (most recent call last):
  File "/usr/lib/anaconda/iw/GroupSelector.py", line 348, in _groupToggled
    self.ayum.deselectGroup(grp.groupid)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 1346, in
deselectGroup
    self.log(4, "package %s was not marked in group %s" % (po, grpid))
NameError: global name 'po' is not defined

Local variables in innermost frame:
thisgroup: Network Servers
self: <yuminstall.AnacondaYum object at 0xb78ec1cc>
txmbr: vnc-server.i386 0-4.1.1-33 - u
pkgname: vnc-server
grpid: network-server
Comment 2 Chris Lumens 2006-01-13 12:19:12 EST
Which password are you seeing in the exception text?  We try to make sure to
remove those before dumping the variables out, but sometimes they are getting
stored in multiple places.  I see one from kickstart right now that I'll remove.
Comment 3 Chris Lumens 2006-01-13 12:26:48 EST
Paul:

diff -ru yum-2.5.1.orig/yum/__init__.py yum-2.5.1/yum/__init__.py
--- yum-2.5.1.orig/yum/__init__.py      2006-01-08 18:59:01.000000000 -0500
+++ yum-2.5.1/yum/__init__.py   2006-01-13 12:29:47.000000000 -0500
@@ -1343,7 +1343,7 @@
                     try:
                         txmbr.groups.remove(grpid)
                     except ValueError:
-                        self.log(4, "package %s was not marked in group %s" %
(po, grpid))
+                        self.log(4, "package %s was not marked in group %s" %
(txmbr.po, grpid))
                         continue

                     # if there aren't any other groups mentioned then remove
the pkg
Comment 4 Alexandre Oliva 2006-01-13 13:51:53 EST
The password that made to the dump file was:

        intf.icw.id.bootloader.password: [omitted]

It does look like the patch will fix the problem, indeed.  From the filename, it
seems like this is not one of those that could be easily dropped in RHupdates,
right? :-(
Comment 5 Chris Lumens 2006-01-13 14:13:57 EST
Yes, you could put it in RHupdates/yum/__init__.py and that should work.

Fixed the password thing, too.
Comment 6 Chris Lumens 2006-01-17 15:56:15 EST
*** Bug 178085 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.