Bug 1777623 - Retire ddiskit in Fedora 32+ or loose the dependency on Python 2
Summary: Retire ddiskit in Fedora 32+ or loose the dependency on Python 2
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ddiskit
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zamir SUN
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1731399 (view as bug list)
Depends On:
Blocks: PY2REMOVAL F31_PY2REMOVAL PYTHON2_EOL
TreeView+ depends on / blocked
 
Reported: 2019-11-28 01:03 UTC by Miro Hrončok
Modified: 2019-11-29 11:37 UTC (History)
13 users (show)

Fixed In Version: ddiskit-3.6-6.20191129gitde1f684.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1778138 (view as bug list)
Environment:
Last Closed: 2019-11-29 11:24:49 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2019-11-28 01:03:42 UTC
In line with the Retire Python 2 Fedora change [0], all (sub)packages of ddiskit were marked for removal.

There was no FESCo exception for this package.

Please retire your package in Rawhide (Fedora 32).

Please don't remove packages from Fedora 31/30/29, removing packages from a released Fedora branch is forbidden and out of scope of this request.

If there is no objection in a week, we will retire the package for you.

We hope this doesn't come to you as a surprise. If you want to know our motivation for this, please read the change document [0].

This text is automated. We are sorry if you already communicated with us about this in another place.

[0] https://fedoraproject.org/wiki/Changes/RetirePython2

Comment 1 Miro Hrončok 2019-11-28 01:09:45 UTC
*** Bug 1731399 has been marked as a duplicate of this bug. ***

Comment 2 Stanislav Kozina 2019-11-29 09:20:08 UTC
PLease don't retire this package. This does come to us as a surprise;-)
We can update ddiskit for Python3, I suppose that is also an option? Should not be hard.
Cestmir, do you think you could take a look at this? Thanks!

Comment 3 Miro Hrončok 2019-11-29 09:52:33 UTC
> This does come to us as a surprise;-)

Sorry about that. What could be improved in our communication?

August: https://bugzilla.redhat.com/show_bug.cgi?id=1731399#c6
October: https://lists.fedoraproject.org/archives/list/devel-announce@lists.fedoraproject.org/message/2GYSDBIY7V66JAJZ6A7UHK657F4DIWPQ/
November: https://lists.fedoraproject.org/archives/list/devel-announce@lists.fedoraproject.org/message/NFMFRKHLPUEDXSADCNXJ2N5YHK2JG3PB/


> We can update ddiskit for Python3, I suppose that is also an option? Should not be hard.

We have tried to talk to you about this in July in bz1731399. Yes, that is the preferred option.


> PLease don't retire this package.

We won't if you give us some reasonable deadline. If you need an "unlimited" exception, request it form FESCo please.

Comment 4 Stanislav Kozina 2019-11-29 10:02:50 UTC
I'm sure the communication was great, it was ignorance on our side.
Looks like even Eugene confirmed that this should be trivial update (just update the interpret and do some testing).
I think we can update the interpret by the end of year, is that sufficient?

Comment 5 Zamir SUN 2019-11-29 10:03:17 UTC
Hi Miro, Stanislav,

If I can get the proper permission, I can make this happen no later than Dec 31st, 2019.

Comment 6 Miro Hrončok 2019-11-29 10:25:01 UTC
> I think we can update the interpret by the end of year, is that sufficient?

I think it is. If I send a PR, would that help?

Comment 7 Zamir SUN 2019-11-29 10:27:38 UTC
After some discussion with Stanislav over IRC, I'm now working on it.

Personally, I'll try to make this happen within 2 weeks.

Comment 8 Zamir SUN 2019-11-29 11:15:15 UTC
Hi Miro,

Now ddiskit supports Python3 in Rawhide

https://src.fedoraproject.org/rpms/ddiskit/c/cdf943ff70b8514f7d2c4736681716d131b044b9?branch=master
https://koji.fedoraproject.org/koji/search?terms=ddiskit-3.6-6.20191129gitde1f684.fc32&type=build&match=glob

However, this bug has title aims at 'Retire', shall I close this bug as FIXED, or close this as WONTFIX?

Thanks.

Comment 9 Miro Hrončok 2019-11-29 11:24:49 UTC
Thanks. Verified:

$ rpm -q --requires -p ddiskit-3.6-6.20191129gitde1f684.fc32.* | grep py
/usr/bin/python3
python(abi) = 3.8
python3-devel
python3-setuptools

Renamed the bug.

Comment 10 Miro Hrončok 2019-11-29 11:30:33 UTC
A quick observation about https://src.fedoraproject.org/rpms/ddiskit/c/cdf943ff70b8514f7d2c4736681716d131b044b9?branch=master


It has a nested if:

  %if 0%{?fedora} >= 25
  %if 0%{?fedora} >= 30



Note that on all RHELs/EPELs, both conditions are false. On all supported Fedoras, both conditions are true. Hence, this is an equivalent:

  %if 0%{?fedora}

Comment 11 Zamir SUN 2019-11-29 11:37:06 UTC
It is intended for now as I don't want to break the backwards-compatibility of the SPEC file.

OTOH it worth a separate bug to track since it's not urgent (just kinda ugly). So cloned to
https://bugzilla.redhat.com/show_bug.cgi?id=1778138

I'll discuss with Stanislav etc. on this.


Note You need to log in before you can comment on or make changes to this bug.