Bug 177779 - Installer doesn't accept timezone change on firstboot
Installer doesn't accept timezone change on firstboot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
: 178209 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-13 16:39 EST by Justin Conover
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 03:33:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Conover 2006-01-13 16:39:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
I select Chicago for my time zone, when you boot into FC it sets it to EST.  Change it again with system-config-date and it does keep the settings. 

This happened with pulling the boot.iso from rawhide date 01-12-06 on x86 and x86_64

Version-Release number of selected component (if applicable):
firstboot-1.3.57-1

How reproducible:
Always

Steps to Reproduce:
1. Download boot.iso
2. Install fc, select timezone, other than EST.  e.g. CST   America/Chicago
3. First boot timezone will be set to EST.
  

Actual Results:  EST was selected for timezone

Expected Results:  CST should have been selected

Additional info:

 rpm -qa firstboot system-config-date
firstboot-1.3.57-1
system-config-date-1.7.99.13-1
Comment 1 Chris Lumens 2006-01-16 11:50:04 EST
Nils, patch is attached below.

Index: scdMainWindow.py
===================================================================
RCS file: /usr/local/CVS/redhat-config-date/src/scdMainWindow.py,v
retrieving revision 1.1
diff -u -r1.1 scdMainWindow.py
--- scdMainWindow.py    9 Jan 2006 23:23:14 -0000       1.1
+++ scdMainWindow.py    16 Jan 2006 16:41:23 -0000
@@ -160,7 +160,11 @@
             self.dateBackend.chkconfigOn()

         #Get the timezone info from the timezone page
-        timezone, utc, arc = self.timezonePage.getTimezoneInfo()
+        if "timezone" in self.showPages:
+            timezone, utc, arc = self.timezonePage.getTimezoneInfo()
+        else:
+            timezone, utc, arc = self.timezoneBackend.getTimezoneInfo()
+
         self.timezoneBackend.writeConfig(timezone, utc, arc)

         if self.closeParent == 1 and not self.firstboot:
Index: timezoneBackend.py
===================================================================
RCS file: /usr/local/CVS/redhat-config-date/src/timezoneBackend.py,v
retrieving revision 1.18
diff -u -r1.18 timezoneBackend.py
--- timezoneBackend.py  7 Oct 2005 11:15:23 -0000       1.18
+++ timezoneBackend.py  16 Jan 2006 16:41:23 -0000
@@ -37,7 +37,7 @@
     def writeConfig (self, timezone, utc=0, arc=0):
         fromFile = "/usr/share/zoneinfo/" + timezone

-        if utc == 0:
+        if utc == 0 or utc == "false":
             utc = "false"
         else:
             utc = "true"
Comment 2 Nils Philippsen 2006-01-17 03:33:43 EST
I've applied the patch in s-c-date-1.7.99.15.
Comment 3 Chris Lumens 2006-01-18 11:37:07 EST
*** Bug 178209 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.