Bug 1777970 - Event sources in topology should be displayed with respective icons
Summary: Event sources in topology should be displayed with respective icons
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Aritra Roy
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-28 20:22 UTC by Aritra Roy
Modified: 2020-01-23 11:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1777969
Environment:
Last Closed: 2020-01-23 11:14:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
event source icons not displayed (15.15 KB, image/png)
2019-11-28 20:22 UTC, Aritra Roy
no flags Details
Event sources in topology should be displayed with respective icons (61.27 KB, image/png)
2020-01-07 22:26 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3608 'None' closed Bug 1777969: fix(knative-icons): show icons for event sources 2020-03-06 10:49:10 UTC
Github openshift console pull 3613 'None' closed Bug 1777970: [release-4.3] fix(knative-icons): show icons for event sources #3613 2020-03-06 10:49:10 UTC

Description Aritra Roy 2019-11-28 20:22:47 UTC
Created attachment 1640496 [details]
event source icons not displayed

+++ This bug was initially created as a clone of Bug #1777969 +++

Description of problem:
Event sources in topology should be displayed with respective icons i.e for cronJob Source/Container Source/ApiServer Source/Camel k Source/Kafka Source.

Steps to Reproduce:
1.Create an event source e.g cronJob
refer to doc https://docs.google.com/document/d/1F4zECoLRvaUiigLaogbgYOiD_hB_w5hAtcXGY0MxVc4/edit

Actual results:
1.The event source is displayed with openshift icon

Expected results:
1.The event source should have been displayed with its respective icon e.g cronJob icon for a cronJob source

Comment 2 Ruchir Garg 2020-01-07 09:57:24 UTC
Assigning defect to Gajanan More for verification.

Comment 3 spathak@redhat.com 2020-01-07 22:25:47 UTC
Verified on build version: 4.3.0-0.ci-2020-01-06-064249

Comment 4 spathak@redhat.com 2020-01-07 22:26:30 UTC
Created attachment 1650518 [details]
Event sources in topology should be displayed with respective icons

Comment 6 errata-xmlrpc 2020-01-23 11:14:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.