Bug 1777980 - Edge Errors on Pipeline Logs
Summary: Edge Errors on Pipeline Logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1778312
TreeView+ depends on / blocked
 
Reported: 2019-11-28 21:00 UTC by Andrew Ballantyne
Modified: 2020-05-04 11:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Microsoft Edge browser didn't recognize the functionality we used for scrolling. Consequence: On MS Edge the Log screen was unable to load and would result in an error. Fix: Checked to see if the functionality was available before trying to use it. Result: Logs could render on MS Edge.
Clone Of:
: 1778312 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:17:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
Error Screen (107.36 KB, image/png)
2019-11-28 21:00 UTC, Andrew Ballantyne
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3612 'None' closed Bug 1777980: Edge Hack - Fix Pipeline Logs 2020-04-21 12:14:21 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:18:13 UTC

Description Andrew Ballantyne 2019-11-28 21:00:04 UTC
Created attachment 1640512 [details]
Error Screen

Description of problem:
Edge is unable to load up the Pipeline logs page.


Version-Release number of selected component (if applicable):


How reproducible:
100%


Steps to Reproduce:
1. Create a Pipeline
2. Start the Pipeline
3. View the Pipeline Run logs

Actual results:
The "Oh no, something went wrong" error page.


Expected results:
Pipeline Logs page.


Additional info:

Comment 1 Andrew Ballantyne 2019-11-29 20:50:00 UTC
Moving to ON_QA since the bot appears to have not done it when the PR was merged on github.

Comment 2 Ruchir Garg 2020-03-02 06:38:42 UTC
Bulk assigning all to Gajanan for verification.

Comment 3 Gajanan More 2020-03-02 07:25:08 UTC
Verified by Abhinandan Das
Equivalent Jira: https://issues.redhat.com/browse/ODC-2402

Comment 6 errata-xmlrpc 2020-05-04 11:17:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.