Bug 177845 - Changes in bz176270 patch break dhcp for DSL-300t modems
Changes in bz176270 patch break dhcp for DSL-300t modems
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks: 177964
  Show dependency treegraph
 
Reported: 2006-01-15 08:19 EST by Tim Fletcher
Modified: 2013-11-24 01:29 EST (History)
0 users

See Also:
Fixed In Version: dhcp-3.0.2-30.FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-01 13:18:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Fletcher 2006-01-15 08:19:13 EST
Description of problem:

The changes to the dhclient support scripts made in dhcp-3.0.2-bz176270.patch
have broken the dhclient when used with the Dlink DSL-300t adsl->ethernet
router. These work by getting an ip for the dsl connection and then bridging
this ip onto the ethernet port, the ethernet port has proxy arp set. They hand
out the ip via dhcp with the default router set to the same as the ip being
handed out hence the proxy arp on the ethernet interface.

I have made a custom rpm of dhcp-3.0.2-28.FC4 with the patch rolled back and the
connection works again. I have also attached the contents of
/var/lib/dhcp/dhclient-eth0.leases:

lease {
  interface "eth0";
  fixed-address 84.12.193.249;
  option subnet-mask 255.255.255.255;
  option routers 84.12.193.249;
  option dhcp-lease-time 60;
  option dhcp-message-type 5;
  option domain-name-servers 213.208.106.212;
  option dhcp-server-identifier 192.168.100.1;
  renew 0 2006/1/15 13:14:50;
  rebind 0 2006/1/15 13:15:11;
  expire 0 2006/1/15 13:15:19;
}



Version-Release number of selected component (if applicable): dhcp-3.0.2-28.FC4 


How reproducible: dhcp an ip address with a router set to the same as the ip
being handed out


Steps to Reproduce:
1. /sbin/ifup eth0
  
Actual results:

no route set in routing table

Expected results:

default route set via ip being handed out
Comment 1 Jason Vas Dias 2006-01-16 13:20:08 EST
This is because the broadcast address is being set to the DHCP IP address
of the interface (netmask == 255.255.255.255) and the dhclient-script refuses
to set the default router to the broadcast address.

No broadcast address should be set if netmask == 255.255.255.255  .

Will fix today with dhcp-3.0.2-30_FC4 / dhcp-3.0.3-20 (FC5) .
Comment 2 Jason Vas Dias 2006-01-16 16:33:19 EST
This bug is now fixed with dhcp-3.0.2-30_FC4 / dhcp-3.0.3-20 (FC5) .
Comment 3 Fedora Update System 2006-01-16 16:46:27 EST
From User-Agent: XML-RPC

dhcp-3.0.2-30.FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 4 Tim Fletcher 2006-01-16 18:44:24 EST
Confirmed, dhcp-3.0.2-30.FC4 fixes this issue for me
Comment 5 Fedora Update System 2006-01-23 22:21:21 EST
From User-Agent: XML-RPC

dhcp-3.0.2-30.FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.