Bug 177964 - Changes in bz176270 patch break dhcp for DSL-300t modems
Changes in bz176270 patch break dhcp for DSL-300t modems
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dhcp (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
: Regression
Depends On: 177845
Blocks: 168430
  Show dependency treegraph
 
Reported: 2006-01-16 16:44 EST by Jason Vas Dias
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2006-0114
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 13:16:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jason Vas Dias 2006-01-16 16:44:35 EST
+++ This bug was initially created as a clone of Bug #177845 +++

Description of problem:

The changes to the dhclient support scripts made in dhcp-3.0.2-bz176270.patch
have broken the dhclient when used with the Dlink DSL-300t adsl->ethernet
router. These work by getting an ip for the dsl connection and then bridging
this ip onto the ethernet port, the ethernet port has proxy arp set. They hand
out the ip via dhcp with the default router set to the same as the ip being
handed out hence the proxy arp on the ethernet interface.

I have made a custom rpm of dhcp-3.0.2-28.FC4 with the patch rolled back and the
connection works again. I have also attached the contents of
/var/lib/dhcp/dhclient-eth0.leases:

lease {
  interface "eth0";
  fixed-address 84.12.193.249;
  option subnet-mask 255.255.255.255;
  option routers 84.12.193.249;
  option dhcp-lease-time 60;
  option dhcp-message-type 5;
  option domain-name-servers 213.208.106.212;
  option dhcp-server-identifier 192.168.100.1;
  renew 0 2006/1/15 13:14:50;
  rebind 0 2006/1/15 13:15:11;
  expire 0 2006/1/15 13:15:19;
}



Version-Release number of selected component (if applicable): dhcp-3.0.2-28.FC4 


How reproducible: dhcp an ip address with a router set to the same as the ip
being handed out


Steps to Reproduce:
1. /sbin/ifup eth0
  
Actual results:

no route set in routing table

Expected results:

default route set via ip being handed out

-- Additional comment from jvdias@redhat.com on 2006-01-16 13:20 EST --
This is because the broadcast address is being set to the DHCP IP address
of the interface (netmask == 255.255.255.255) and the dhclient-script refuses
to set the default router to the broadcast address.

No broadcast address should be set if netmask == 255.255.255.255  .

Will fix today with dhcp-3.0.2-30_FC4 / dhcp-3.0.3-20 (FC5) .


-- Additional comment from jvdias@redhat.com on 2006-01-16 16:33 EST --
This bug is now fixed with dhcp-3.0.2-30_FC4 / dhcp-3.0.3-20 (FC5) .
Comment 1 Jason Vas Dias 2006-01-16 16:49:41 EST
Fixed with dhcp-3.0.1-54.EL4 .
Comment 6 Red Hat Bugzilla 2006-03-07 13:16:26 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0114.html

Note You need to log in before you can comment on or make changes to this bug.