Bug 177863 - gaim-1.5.0-13.fc5 segfaults on startup
gaim-1.5.0-13.fc5 segfaults on startup
Status: CLOSED DUPLICATE of bug 178005
Product: Fedora
Classification: Fedora
Component: gaim (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-15 15:31 EST by Ian Burrell
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 12:18:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Burrell 2006-01-15 15:31:50 EST
gaim-1.5.0-13.fc5.x86_64 segfaults on startup.  This is with up-to-date rawhide.
 gaim-1.5.0-9.fc5.3.x86_64 worked fine.

Stack trace:

(gdb) thread apply all bt

Thread 1 (process 4594):
#0  0x00002aaaacafa215 in *__GI_raise (sig=Variable "sig" is not available.
) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x00002aaaacafb93e in *__GI_abort () at abort.c:88
#2  0x00005555556143d2 in sighandler (sig=4594) at main.c:368
#3  <signal handler called>
#4  check_derivation_I (parent_type=1433919184, type_name=0x2aaaab9793e5
"GtkObject")
    at gtype.c:423
#5  0x00002aaaac3fe509 in IA__g_type_register_static (parent_type=1433919184,
    type_name=0x2aaaab9793e5 "GtkObject", info=0x2aaaabaf3ec0,
flags=G_TYPE_FLAG_ABSTRACT)
    at gtype.c:2220
#6  0x00002aaaab83197b in IA__gtk_object_get_type () at gtkobject.c:98
#7  0x00002aaaab8e25c8 in IA__gtk_widget_get_type () at gtkwidget.c:291
#8  0x00002aaaab7a129a in IA__gtk_container_get_type () at gtkcontainer.c:137
#9  0x00002aaaab76e462 in IA__gtk_bin_get_type () at gtkbin.c:69
#10 0x00002aaaab8ed4e6 in IA__gtk_window_get_type () at gtkwindow.c:320
#11 0x00002aaaab8f14d6 in IA__gtk_window_new (type=GTK_WINDOW_TOPLEVEL) at
gtkwindow.c:1037
#12 0x00005555556166b4 in gaim_gtk_stock_init () at stock.c:143
#13 0x000055555561425f in gaim_gtk_ui_init () at main.c:460
#14 0x0000555555595daa in gaim_core_init (ui=Variable "ui" is not available.
) at core.c:99
#15 0x00005555556154df in main (argc=1, argv=0x7fffffbf67a8) at main.c:870

bt full did not return the full stack trace.

#4  check_derivation_I (parent_type=1433919184, type_name=0x2aaaab9793e5
"GtkObject")
    at gtype.c:423
        pnode = (TypeNode *) 0x5577ded0
        finfo = Variable "finfo" is not available.
#5  0x00002aaaac3fe509 in IA__g_type_register_static (parent_type=1433919184,
    type_name=0x2aaaab9793e5 "GtkObject", info=0x2aaaabaf3ec0,
flags=G_TYPE_FLAG_ABSTRACT)
    at gtype.c:2220
        pnode = Variable "pnode" is not available.
#6  0x00002aaaab83197b in IA__gtk_object_get_type () at gtkobject.c:98
        object_info = {class_size = 160,
  base_init = 0x2aaaab830f90 <gtk_object_base_class_init>,
  base_finalize = 0x2aaaab830fa7 <gtk_object_base_class_finalize>,
  class_init = 0x2aaaab8323c5 <gtk_object_class_init>, class_finalize = 0,
class_data = 0x0,
  instance_size = 32, n_preallocs = 16, instance_init = 0x2aaaab830fa8
<gtk_object_init>,
  value_table = 0x0}
        object_type = 0
#7  0x00002aaaab8e25c8 in IA__gtk_widget_get_type () at gtkwidget.c:291
        accessibility_info = {
  interface_init = 0x2aaaab8e1929 <gtk_widget_accessible_interface_init>,
  interface_finalize = 0, interface_data = 0x0}
        widget_info = {class_size = 720, base_init = 0, base_finalize = 0,
  class_init = 0x2aaaab8e855a <gtk_widget_class_init>, class_finalize = 0,
class_data = 0x0,
  instance_size = 96, n_preallocs = 0, instance_init = 0x2aaaab8e1f41
<gtk_widget_init>,
  value_table = 0x0}
        widget_type = 0
#8  0x00002aaaab7a129a in IA__gtk_container_get_type () at gtkcontainer.c:137
        container_info = {class_size = 824,
  base_init = 0x2aaaab7a0940 <gtk_container_base_class_init>,
  base_finalize = 0x2aaaab7a414c <gtk_container_base_class_finalize>,
  class_init = 0x2aaaab7a36e2 <gtk_container_class_init>, class_finalize = 0,
  class_data = 0x0, instance_size = 112, n_preallocs = 0,
  instance_init = 0x2aaaab7a0957 <gtk_container_init>, value_table = 0x0}
        container_type = 0
#9  0x00002aaaab76e462 in IA__gtk_bin_get_type () at gtkbin.c:69
        bin_info = {class_size = 824, base_init = 0, base_finalize = 0,
  class_init = 0x2aaaab76e4de <gtk_bin_class_init>, class_finalize = 0,
class_data = 0x0,
  instance_size = 120, n_preallocs = 0, instance_init = 0x2aaaab76e410
<gtk_bin_init>,
  value_table = 0x0}
        bin_type = 0
#10 0x00002aaaab8ed4e6 in IA__gtk_window_get_type () at gtkwindow.c:320
        window_info = {class_size = 904, base_init = 0, base_finalize = 0,
  class_init = 0x2aaaab8f1897 <gtk_window_class_init>, class_finalize = 0,
class_data = 0x0,
  instance_size = 240, n_preallocs = 0, instance_init = 0x2aaaab8f1519
<gtk_window_init>,
  value_table = 0x0}
        window_type = 0
#11 0x00002aaaab8f14d6 in IA__gtk_window_new (type=GTK_WINDOW_TOPLEVEL) at
gtkwindow.c:1037
        __PRETTY_FUNCTION__ = "IA__gtk_window_new"
#12 0x00005555556166b4 in gaim_gtk_stock_init () at stock.c:143
        icon_factory = (GtkIconFactory *) 0x55555577cae0
        win = Variable "win" is not available.
#13 0x000055555561425f in gaim_gtk_ui_init () at main.c:460
No locals.
#14 0x0000555555595daa in gaim_core_init (ui=Variable "ui" is not available.
) at core.c:99
        ops = (GaimCoreUiOps *) 0x555555746180
        core = Variable "core" is not available.
#15 0x00005555556154df in main (argc=1, argv=0x7fffffbf67a8) at main.c:870
        opt_acct = 0
        opt_help = 0
        opt_version = 0
        opt_login = 0
        opt_nologin = 0
        dologin_ret = Variable "dologin_ret" is not available.
Comment 1 Peter Lawler 2006-01-16 20:47:42 EST
given what actually changed betweeen -9.fc5.3 and -13.fc5, that is *definitely*
not a gaim bug :
http://cvs.fedora.redhat.com/viewcvs/rpms/gaim/devel/gaim.spec?r1=1.109&r2=1.110

(says nosnilmot in #gaim)
Comment 2 Warren Togami 2006-01-16 21:57:16 EST
Jakub and Ulrich, any idea if any gcc bug happened here?
Comment 3 Ian Burrell 2006-01-16 23:02:09 EST
I suspect the problem is with gtk2.  I tried installing earlier devel versions
of gaim; both gaim-1.5.0-9.fc5.2.x86_64 and gaim-1.5.0-9.fc5.3.x86_64
segfaulted.  Since the segfault is happening inside gtk_window_new, I tried an
earlier version of gtk2.  gaim-1.5.0-13.fc5.x86_64 works fine with
gtk2-2.8.9-1.1.x86_64 but segfaults with gtk2-2.8.10-2.x86_64.
Comment 4 Michel Alexandre Salim 2006-01-17 13:19:49 EST
It does look like the culprit is the new gtk2. It also breaks Java applications
if the LookAndFeel is set to GTK (NetBeans 5 RC1 works with GTK2 2.8.9 but not
with 2.8.10)
Comment 5 Warren Togami 2006-01-17 13:52:43 EST
Hey desktop folks, testers have indicated that newer versions of gtk2 are
causing gaim to segfault.  Any idea what's going on?
Comment 6 Warren Togami 2006-01-17 14:15:34 EST
http://people.redhat.com/wtogami/temp/gaim-1.5.0-13.fc5.test.i386.rpm
Hey everyone running the latest rawhide, please test this i386-only rebuild of
the latest gaim package.  Does this behave any better with the latest gtk2 and
all other rawhide packages?  Please let us know soon.
Comment 7 Matthias Clasen 2006-01-17 14:36:58 EST
IS this an x86_64 only crash ?
Comment 8 Sammy 2006-01-17 20:26:19 EST
It seems like it. I have two systems at identical level, one i686 one x86_64.
gaim is working on i386 but instantly segfaulting on x86_64.
Comment 9 Pekka Pietikäinen 2006-01-18 12:18:40 EST
I just verified downgrading to gtk2-2.8.9-1.1.x86_64.rpm fixes gaim -> marking
as dupe of original bug (#178005). That seems to be on ia64 -> it's a gtk2 broke
on 64-bit platforms between 2.8.9 and 2.8.10 bug.

*** This bug has been marked as a duplicate of 178005 ***

Note You need to log in before you can comment on or make changes to this bug.