Bug 178005 - gtk2 package from January 14th broke rhgb/GNOME (at least)
gtk2 package from January 14th broke rhgb/GNOME (at least)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Matthias Clasen
:
: 177863 (view as bug list)
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-01-17 04:27 EST by Émeric Maschino
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-24 07:33:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Émeric Maschino 2006-01-17 04:27:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

Description of problem:
rhgb no longer works and when starting a GNOME session, the plain blue color background (below the Fedora Core background image) and the cross mouse cursor is displayed for a few milliseconds and then I'm back to the console. I can't find useful informations in the logs.

Version-Release number of selected component (if applicable):
gtk2-2.8.10-2

How reproducible:
Always

Steps to Reproduce:
1. Update to gtk2-2.8.10-2
2. Restart gdm or manually start up a GNOME session with startx
3.
  

Actual Results:  rhgb and a GNOME session can't be started anymore. gdm tries to start a GNOME session several times but it's finally suspended for two minutes because the X server is jointly started 6 times during the past 95 seconds without success.

Expected Results:  rhgb should display the boot informations and I should be able to start a GNOME session with gdm or startx.

Additional info:

Reverting to gtk2-2.8.9-1.1 solves the problem. But gnome-volume-manager and the GNOME applets won't work. To correct this, revert back to gnome-volume-manager-1.5.7-2 and gnome-session-2.12.0-5. Thus, everything is fine like previously.
Comment 1 Pekka Pietikäinen 2006-01-18 12:19:14 EST
*** Bug 177863 has been marked as a duplicate of this bug. ***
Comment 2 Sammy 2006-01-18 14:36:51 EST
I think the crash is happening in glib2. gtk2-2.8.10 release notes makes a
point about requiring glib2-2.8.5. Since there seems to be abi differences
between the two, could this be the source of the problem?
Comment 3 Matthias Clasen 2006-01-19 07:30:40 EST
Please try with gtk 2.8.10-3
There was a crasher bug on 64bit platforms that was fixed.
Comment 4 Émeric Maschino 2006-01-20 03:29:04 EST
gtk2 2.8.10-3 solves the problem. My GNOME desktop is back, but all the applets
(clock, desktop switcher, volume sound, etc.) are crashing at startup.
Comment 5 Michel Alexandre Salim 2006-01-20 19:34:41 EST
I can confirm that the fix works on x86_64 as well. Gaim now works, thanks.
Comment 6 Émeric Maschino 2006-01-20 20:41:23 EST
With today updates, the GNOME applets are working correctly. Great job girls and
guys!
Comment 7 Émeric Maschino 2006-01-20 21:34:39 EST
I just noticed that gnome-panel is crashing when you log out a GNOME session.
Comment 8 Émeric Maschino 2006-01-20 21:40:19 EST
(In reply to comment #7)
> I just noticed that gnome-panel is crashing when you log out a GNOME session.

In fact, it crashes when you check "Enable software sound mixing (ESD)" in the
sound preferences.
Comment 9 Ian Burrell 2006-01-21 16:13:27 EST
gaim is working fine now on x86_64.
Comment 10 Matthias Clasen 2006-01-24 07:33:41 EST
Thanks for testing

Note You need to log in before you can comment on or make changes to this bug.