Bug 177866 - gnome-volume-manager crashes when logging in
gnome-volume-manager crashes when logging in
Status: CLOSED DUPLICATE of bug 177806
Product: Fedora
Classification: Fedora
Component: gnome-volume-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-15 16:14 EST by Ian Burrell
Modified: 2013-03-13 00:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-16 16:47:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Burrell 2006-01-15 16:14:05 EST
Description of problem:

gnome-volume-manager segfaults when first logging in.  After "Restarting" from
the crash dialog or starting it manually from the command line, it starts fine.

Version:

gnome-volume-manager-1.5.9-1.x86_64

I think the following message in session log comes from gnome-volume-manager:

GnomeUI-CRITICAL **: gnome_client_set_id: assertion `!GNOME_CLIENT_CONNECTED
(client)' failed
aborting...

Stack trace:

(gdb) thread apply all bt
Thread 1 (process 5676):
#0  0x00000036ab12f215 in *__GI_raise (sig=Variable "sig" is not available.
) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x00000036ab13093e in *__GI_abort () at abort.c:88
#2  0x0000003adc052706 in libgnomeui_segv_handle (signum=5) at gnome-ui-init.c:793
#3  <signal handler called>
#4  IA__g_logv (log_domain=0x3adc061dbf "GnomeUI", log_level=Variable
"log_level" is not available.
) at gmessages.c:502
#5  0x00000036acd2c34a in IA__g_log (log_domain=Variable "log_domain" is not
available.
) at gmessages.c:517
#6  0x0000003a5d602597 in invokeCallbacksOPTION (con=0x524e20, opt=0x3adc18f040,
    myOpt=0x3adc18f040, myData=0x3adc078e2e, shorty=0) at popt.c:159
#7  0x0000003a5d6025d0 in invokeCallbacksOPTION (con=0x524e20, opt=0x526550,
    myOpt=0x3adc18f040, myData=0x3adc078e2e, shorty=0) at popt.c:139
#8  0x0000003a5d6033b5 in poptGetNextOpt (con=0x524e20) at popt.c:974
#9  0x0000000000405c9a in main (argc=7, argv=Variable "argv" is not available.
) at manager.c:2494
#10 0x00000036ab11cde4 in __libc_start_main (main=0x405be5 <main>, argc=7,
    ubp_av=0x7fffffc37748, init=Variable "init" is not available.
) at libc-start.c:231
#11 0x0000000000403da9 in _start ()
#12 0x00007fffffc37738 in ?? ()
#13 0x0000000000000000 in ?? ()
Comment 1 Ian Burrell 2006-01-16 16:47:46 EST

*** This bug has been marked as a duplicate of 177806 ***

Note You need to log in before you can comment on or make changes to this bug.