Bug 1779014 - Inconsisteny in Object service Dashboard Unavailable statuses
Summary: Inconsisteny in Object service Dashboard Unavailable statuses
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.4.0
Assignee: afrahman
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks: 1779492
TreeView+ depends on / blocked
 
Reported: 2019-12-03 04:32 UTC by afrahman
Modified: 2020-05-13 21:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Console dashboards are using "Not available" status rather than "Available" and this updtae is missed at some parts on storage dashboards Consequence: Inconsistent UI Fix: Changed "Unavaliable" to "Not available" Result: Consistent statuses across console
Clone Of:
: 1779492 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:53:33 UTC
Target Upstream Version:


Attachments (Terms of Use)
Verification of statuses in 4.4 build (155.01 KB, image/png)
2019-12-09 08:52 UTC, afrahman
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3636 'None' closed Bug 1779014: Fixes for dashboard cards 2020-05-08 10:44:12 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:53:36 UTC

Description afrahman 2019-12-03 04:32:52 UTC
Description of problem:

1. The status of MCG is showing not running on Object service dahsboard but on Persistent it says "Not available" when no OCS is deployed.

2. Buckets card show "Unavailable" when other dashboard says "Not available"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Install OCS Operator(not installing storage cluster)
2.Go to OCS Object Service Dashboard
3.Match MCG status in status card with that of OCS PV and look the status on Bucket Card

Actual results:

1. The status of MCG is showing not running on Object service dahsboard but on Persistent it says "Not available" when no OCS is deployed.

2. Buckets card show "Unavailable" when other dashboard says "Not available"


Expected results:

1. MCG status should be "Not available"
2. Buckets card status should be "Not available"

Additional info:

Comment 1 afrahman 2019-12-09 08:52:56 UTC
Created attachment 1643227 [details]
Verification of statuses in 4.4 build

Verified with openshift-install-linux-4.4.0-0.ci-2019-12-09-025401 build

Comment 3 errata-xmlrpc 2020-05-13 21:53:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.