Bug 1779492 - Inconsisteny in Object service Dashboard Unavailable statuses
Summary: Inconsisteny in Object service Dashboard Unavailable statuses
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.3.0
Assignee: afrahman
QA Contact: Anna Sandler
URL:
Whiteboard:
Depends On: 1779014
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-04 04:48 UTC by afrahman
Modified: 2020-01-23 11:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1779014
Environment:
Last Closed: 2020-01-23 11:17:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3660 0 'None' 'open' '[release-4.3] Bug 1779492: Fixes for dashboard cards' 2019-12-04 04:50:35 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:18:04 UTC

Description afrahman 2019-12-04 04:48:25 UTC
+++ This bug was initially created as a clone of Bug #1779014 +++

Description of problem:

1. The status of MCG is showing not running on Object service dahsboard but on Persistent it says "Not available" when no OCS is deployed.

2. Buckets card show "Unavailable" when other dashboard says "Not available"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Install OCS Operator(not installing storage cluster)
2.Go to OCS Object Service Dashboard
3.Match MCG status in status card with that of OCS PV and look the status on Bucket Card

Actual results:

1. The status of MCG is showing not running on Object service dahsboard but on Persistent it says "Not available" when no OCS is deployed.

2. Buckets card show "Unavailable" when other dashboard says "Not available"


Expected results:

1. MCG status should be "Not available"
2. Buckets card status should be "Not available"

Additional info:

Comment 2 Anna Sandler 2019-12-22 09:34:20 UTC
all the statuses on Object service dashboard are shown as "Not available" when no OCS is deployed.

Comment 3 Anna Sandler 2019-12-22 10:04:30 UTC
OCP version 4.3.0-0.nightly-2019-12-21-210057

Comment 5 errata-xmlrpc 2020-01-23 11:17:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.