Bug 1779230 - QuiteRSS >0.19.0 does not use <0.18.12 settings and feeds
Summary: QuiteRSS >0.19.0 does not use <0.18.12 settings and feeds
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: quiterss
Version: 31
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Eugene A. Pivnev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-03 14:44 UTC by ValdikSS
Modified: 2020-07-30 08:06 UTC (History)
2 users (show)

Fixed In Version: quiterss-0.19.2-3.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-08 02:00:40 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github QuiteRSS quiterss issues 1023 'None' closed Can't migrate settings 2020-07-30 08:06:00 UTC

Description ValdikSS 2019-12-03 14:44:57 UTC
Description of problem:

After updating from Fedora 30 (where quiterss-0.18.12-3.fc30 is the latest) to 31 with quiterss-0.19.0-1.fc31, I can no longer see my RSS feeds. The program starts like it's a first run.
I reported this problem in Bohdi Fedora 30 build of 0.19.0 version: https://bodhi.fedoraproject.org/updates/FEDORA-2019-7a72d69956

Version-Release number of selected component (if applicable):
quiterss-0.19.0-1.fc31


How reproducible:
Always


Steps to Reproduce:
1. Install QuiteRSS 0.18.12 or earlier and configure it
2. Upgrade to QuiteRSS 0.19.0 or newer

Actual results:
No old configuration is used.

Expected results:
Old configuration is used, old RSS feeds are readable.

Comment 1 ValdikSS 2019-12-03 14:56:41 UTC
Fixed by moving ~/.local/share/data/QuiteRss/QuiteRss to ~/.local/share/QuiteRss/QuiteRss.
Patch in bug 1485714 doesn't seem to be applied.

Comment 2 Christian Stadelmann 2019-12-04 00:00:24 UTC
(In reply to ValdikSS from comment #1)
> Fixed by moving ~/.local/share/data/QuiteRss/QuiteRss to
> ~/.local/share/QuiteRss/QuiteRss.
> Patch in bug 1485714 doesn't seem to be applied.

I'd rather call this a workaround than a bug.

For reference: A patch can be found in this pull request: https://src.fedoraproject.org/rpms/quiterss/pull-request/2#request_diff

@Ti.Eugene: I've had the patches lying around for 2 years. Can you please include them?

Comment 3 Christian Stadelmann 2019-12-04 00:14:04 UTC
By the way: Upstream decided to ignore this bug: https://github.com/QuiteRSS/quiterss/issues/1023

Comment 4 Eugene A. Pivnev 2019-12-10 10:53:07 UTC
I not applied that patch because quiterss 18.x was not built with qt5 at all (too many errors on compiling).
I'm tryinig to solve problem (https://github.com/QuiteRSS/quiterss/issues/1228), but today workaround above is best way.
Seems it is not bug because qt4 and qt5 paths are incompatible with each another ("This is not a bug - this is a feature" (c)).

I propose to
1) publish quiterss 19.2 into repos as is (it is not published yet because of this bug report)
2) close this bug with NEXTRELEASE flag (or NOTABUG)
3) and wait for solving in upstream sources as developers will deside.

Comment 5 Christian Stadelmann 2020-01-13 11:29:18 UTC
(In reply to Eugene A. Pivnev from comment #4)
> I not applied that patch because quiterss 18.x was not built with qt5 at all
> (too many errors on compiling).
> I'm tryinig to solve problem
> (https://github.com/QuiteRSS/quiterss/issues/1228), but today workaround
> above is best way.
> Seems it is not bug because qt4 and qt5 paths are incompatible with each
> another ("This is not a bug - this is a feature" (c)).
> 
> I propose to
> 1) publish quiterss 19.2 into repos as is (it is not published yet because
> of this bug report)
> 2) close this bug with NEXTRELEASE flag (or NOTABUG)
> 3) and wait for solving in upstream sources as developers will deside.

That's fine with me.

Comment 6 Eugene A. Pivnev 2020-01-29 11:10:24 UTC
(In reply to Christian Stadelmann from comment #5)
> (In reply to Eugene A. Pivnev from comment #4)
> > I not applied that patch because quiterss 18.x was not built with qt5 at all
> > (too many errors on compiling).
> > I'm tryinig to solve problem
> > (https://github.com/QuiteRSS/quiterss/issues/1228), but today workaround
> > above is best way.
> > Seems it is not bug because qt4 and qt5 paths are incompatible with each
> > another ("This is not a bug - this is a feature" (c)).
> > 
> > I propose to
> > 1) publish quiterss 19.2 into repos as is (it is not published yet because
> > of this bug report)
> > 2) close this bug with NEXTRELEASE flag (or NOTABUG)
> > 3) and wait for solving in upstream sources as developers will deside.
> 
> That's fine with me.

Don't forget to remove old db (rm -f ~/.local/share/QuiteRss/QuiteRss/feeds.db) before starting new (0.19.2-3) build.
(if you want to import old feeds).

Comment 7 Fedora Update System 2020-01-29 11:27:23 UTC
FEDORA-2020-06a00afcaf has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-06a00afcaf

Comment 8 Fedora Update System 2020-01-31 01:29:42 UTC
quiterss-0.19.2-3.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-06a00afcaf

Comment 9 Fedora Update System 2020-02-08 02:00:40 UTC
quiterss-0.19.2-3.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.