Bug 1779493 - Topology edit actions should be disabled if the user does not have correct permission
Summary: Topology edit actions should be disabled if the user does not have correct pe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Vikram Raj
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-04 04:52 UTC by Vikram Raj
Modified: 2020-05-04 11:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1779915 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:18:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3484 'None' closed Bug 1779493: Disabled edit actions if the user has no permission 2020-04-22 18:38:54 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:18:49 UTC

Description Vikram Raj 2019-12-04 04:52:39 UTC
Description of problem:
If the user does not have permission to perform these actions they should not be shown / available.

Version-Release number of selected component (if applicable): 4.3.0


How reproducible:


Steps to Reproduce:
1. Log in as a non-admin user. And visit the topology page of a project which is not created by you.
2. On hover over a node, you will see the connector, context menu by right-clicking on the node and able to regroup by drag and drop of the node.

Actual results:
On hover over a node, you will see the connector, context menu by right-clicking on the node and able to regroup by drag and drop of the node.

Expected results:
If the user has only read access to a namespace then on hover over a node, the user should not see the connector, should not see the context menu on right-click on a node and not able to regroup the application by drag and drop.

Additional info:

Comment 2 Gajanan More 2020-03-04 12:32:48 UTC
I have validated this bug on 
Build:4.4.0-0.nightly-2020-03-04-000622 
Browser:Google Chrome Version 78.0.3904.108
Marking this bug as verified

Comment 4 errata-xmlrpc 2020-05-04 11:18:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.