Bug 1779915 - Topology edit actions should be disabled if the user does not have correct permission
Summary: Topology edit actions should be disabled if the user does not have correct pe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: cvogt
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-05 01:12 UTC by Vikram Raj
Modified: 2020-03-24 10:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1779493
Environment:
Last Closed: 2020-01-23 11:17:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
The bug has validated successfully and this is the screenshot of it.l (160.50 KB, image/png)
2020-01-07 09:25 UTC, Gajanan More
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3676 'None' closed [release-4.3]Bug 1779915: Disabled edit actions if the user has no permission 2020-05-21 06:07:58 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:18:04 UTC

Description Vikram Raj 2019-12-05 01:12:00 UTC
+++ This bug was initially created as a clone of Bug #1779493 +++

Description of problem:
If the user does not have permission to perform these actions they should not be shown / available.

Version-Release number of selected component (if applicable): 4.3.0


How reproducible:


Steps to Reproduce:
1. Log in as a non-admin user. And visit the topology page of a project which is not created by you.
2. On hover over a node, you will see the connector, context menu by right-clicking on the node and able to regroup by drag and drop of the node.

Actual results:
On hover over a node, you will see the connector, context menu by right-clicking on the node and able to regroup by drag and drop of the node.

Expected results:
If the user has only read access to a namespace then on hover over a node, the user should not see the connector, should not see the context menu on right-click on a node and not able to regroup the application by drag and drop.

Additional info:

Comment 2 Gajanan More 2020-01-07 09:25:10 UTC
Created attachment 1650320 [details]
The bug has validated successfully and this is the screenshot of it.l

Comment 3 Gajanan More 2020-01-07 09:28:48 UTC
I have validated the bug on the cluster with
Build: 4.3.0-0.nightly-2020-01-06-185654
Browser: Chrome Version 78.0.3904.108

Comment 4 Ruchir Garg 2020-01-07 09:57:22 UTC
Assigning defect to Gajanan More for verification.

Comment 6 errata-xmlrpc 2020-01-23 11:17:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.