Bug 177979 - Package manager crashes while resovling Dependency
Package manager crashes while resovling Dependency
Status: CLOSED DUPLICATE of bug 177973
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-16 18:46 EST by Don Springall
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 12:27:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Don Springall 2006-01-16 18:46:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
Get the following error while adding packages:
Component: Software Manager
Summary: TBb4cd5369 __init__.py:410:depDetails:NameError: global name 'pango' is not defined

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 298, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 536, in applyChanges
    self.depDetails(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 410, in depDetails
    tag.set_property('weight', pango.WEIGHT_BOLD)
NameError: global name 'pango' is not defined

Local variables in innermost frame:
mainwin: <gtk.Window object (GtkWindow) at 0xb5612a04>
self: <__main__.PackageManager object at 0xb7aa480c>
b: <gtk.TextBuffer object (GtkTextBuffer) at 0xcd1e6e4>
tag: <gtk.TextTag object (GtkTextTag) at 0xcd1ed24>
d: <pirut.DetailsDialog.PirutDetailsDialog instance at 0xb08c1cc>


Version-Release number of selected component (if applicable):
pirut-0.9.4-1

How reproducible:
Always

Steps to Reproduce:
1.Select packages to install
2.Hit update button
3.Kaboom
  

Actual Results:  Pirut backtraced.

Expected Results:  Download package.

Additional info:

pango-1.11.1-2 installed. Kernel 2.6.15-git11
Comment 1 Jeremy Katz 2006-01-18 12:27:36 EST

*** This bug has been marked as a duplicate of 177973 ***

Note You need to log in before you can comment on or make changes to this bug.