Bug 178030 - Keyboard mapping not loaded in anaconda
Keyboard mapping not loaded in anaconda
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
: 178371 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-17 10:21 EST by Christian Kalkhoff
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-05 09:17:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Kalkhoff 2006-01-17 10:21:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
When choosing the keyboard mapping in anaconda the chosen value has no effect on the ananconda instance. After rebooting the system the keymap is properly set.

This becomes a problem if your root password contains special characters like $%&/  or on a german keyboard "z" or "y".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start installer
2.Choose Language/Keyboard german
3.Enter root password with special char like %& or z and y on german
4.Complete installation
5.Try to login
  

Actual Results:  I am not able to login with the root password (in keys) that i entered during installation.

Expected Results:  I should have been able to login with the password (in keys) that i entered during installation

Additional info:
Comment 1 David Cantrell 2006-01-17 14:23:10 EST
What installation method are you using (CD, net, floppy...)?
Comment 2 Christian Kalkhoff 2006-01-17 15:37:18 EST
I use installation from dvd  
Comment 3 Chris Lumens 2006-01-19 16:54:56 EST
*** Bug 178371 has been marked as a duplicate of this bug. ***
Comment 4 David Cantrell 2006-01-23 12:05:22 EST
Please boot the installation media again.  During the text mode initialization,
select the language and keymap and other settings.  Once the graphical portion
of the installer has started, switch over to tty2 (Ctrl+Alt+F2) and capture the
output of this command:

ps -ef | grep anac

Paste that here.  It should be two lines.

Thanks.
Comment 5 Christian Kalkhoff 2006-01-23 12:16:07 EST
Dont understand what you mean. I switch language and keymap in graphic mode. 
Comment 6 David Cantrell 2006-01-23 12:54:00 EST
The language and keymap selection happen before anaconda loads.  The screen is
different.  Blue background with text-style windows.  Anaconda starts after you
see this text at the bottom of the screen:

Running anaconda, the Fedora Core system installer - please wait...

The X server is started and anaconda launched.  Once you are at the welcome
screen (displays the logo and has a Next button and a Release Notes button),
press Ctrl+Alt+F2 to get to the shell on tty2.  Run the command mentioned above
and copy the output here.
Comment 7 David Cantrell 2006-01-27 14:25:46 EST
Can you try installing using a rescue image from rawhide.  We had a number of
other keyboard errors reported for FC5t2 and  I want to know if this one was
cleared up with our recent changes.

http://download.fedora.redhat.com/pub/fedora/linux/core/development/isos/
Comment 8 Thomas Canniot 2006-01-28 14:45:06 EST
Here is my feedback concerning the ps -ef | grep anac command you asked about : 

root 488 289 0 19:40 ?    00:00:02 /usr/bin/python /usr/bin/anaconda -m
cdrom://hdc:/mnt/source --graphical --selinux
root 498 488 0 19:41 ?    00:00:01 /usr/bin/python /usr/bin/anaconda -m
cdrom://hdc:/mnt/source --graphical --selinux

Hope this will help...

About the rescuecd-i386.iso, I was not able to load any images during the rescue
process but whatever I choose between fr-latin1, fr-latin9 and fr-pc, the
"Directory holding images" field had an azerty french layout. Seems to be fixed
then.
Comment 9 John Thacker 2006-05-05 09:17:49 EDT
Closing, since previous comment indicates that it seems to be fixed.

Note You need to log in before you can comment on or make changes to this bug.