Bug 1780338 - Missing che icon in topology edit source decorator
Summary: Missing che icon in topology edit source decorator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Karthik Jeeyar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-05 17:43 UTC by Karthik Jeeyar
Modified: 2020-05-04 11:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: When che is configured and the edit source decorator is present on a topology node with a link to che, the icon is still showing a git icon. Consequence: User is not notified that che is configured and by clicking the decorator, they would be taken to the che workspace. Fix: If che is configured and if the user visits the topology, the workloads should have the che icon as the decorator. Result: Decorator should show and hint the user that on clicking that decorator, they should be taken to the che workspaces.
Clone Of:
: 1780953 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:18:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3629 0 'None' closed Bug 1780338: fix(che-icon): add che Icon in the topology 2020-04-20 09:23:48 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:19:10 UTC

Description Karthik Jeeyar 2019-12-05 17:43:04 UTC
Description:

When che is configured and the edit source decorator is present on a topology node with a link to che, the icon is still showing a git icon. It should be a che icon

Steps to Reproduce:
1.Install a che operator
2.In topology edit source decorator should have che icon instead of git icon

Actual results:
After Installing che operator, still edit source decorator in topology is showing git icon

Expected results:

After Installing che operator, still edit source decorator in topology should show che icon

Comment 2 Gajanan More 2020-03-02 12:23:53 UTC
https://issues.redhat.com/browse/ODC-2383 verified by Gajanan More

Comment 4 errata-xmlrpc 2020-05-04 11:18:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.